1
\$\begingroup\$

I use two Godox SK300 II strobes. When I use them I have tried putting them on separate groups with the Xpro transmitter but one fires and the other does not. Even if I switch off the one that fires, the second one won't fire. I cannot get it to fire on any channel or group. Any ideas?

\$\endgroup\$
4

1 Answer 1

0
\$\begingroup\$

Everything has to be set to the same channel. Make sure your transmitter and both SK300 II are using the same channel setting.

If there's radio interference, try changing channels to something higher in the range. If you have another Godox unit with the SCAN function (V1, V860 III, TT685 II, Xpro II, X2T), try using that to find the least-crowded radio channels. Or, if there's an obvious source of RF (e.g., a wi-fi router), consider moving the lights farther away from that. Radio, like light, is electromagnetic radiation and also obeys the inverse square law.

On the XPro transmitter, make sure both of the groups that you have assigned to the strobes are set to be on and firing. By default the XPro can only display and set Groups A-E, but the SK300 IIs can use Groups F, and 0-9 as well. If you have set either of the SK300 II to those groups, you have to make sure that the Xpro's GROUP setting is set to 16 (0-F) and not 5 (A-E), so you can scroll through all 16 groups.

If you are using the strobes very close to the transmitter, make sure the DIST setting on the XPro is set to 0-30m, not the default 1-100m.

\$\endgroup\$
2
  • \$\begingroup\$ I do believe it is the SK300 II, they are both set to the same Channel, I want them set to different groups as to apply different setting. I can achieve this by setting the 2nd one as slave with only the Master being triggered. If I turn slave off it does not trigger. I can get it to trigger from the remote if I turn my master off and reset the wifi on the slave by turning it off and on again. Then it triggers from the XPro. As soon as I turn the Master back on the slave stops triggering. \$\endgroup\$ Commented Feb 1 at 22:51
  • \$\begingroup\$ @WadeCramer, That makes no sense to me. Both strobes should be in radio slave mode (NOT optical S1 or S2). If you want to set each one individually, you assign one SK300 II to Group A, you assign the other one to Group B. Then on the transmitter, you make sure Groups A and B are both turned on and in M mode (because the SK300 II cannot perform TTL). \$\endgroup\$
    – inkista
    Commented Feb 3 at 22:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.