0
\$\begingroup\$

I have Lightroom Classic 12.4 on my laptop and desktop, and store all my photos on my Synology NAS. I edit my photos locally on my laptop using Lightroom Classic, then (when I'm home) I use Lightroom Classic to move them to my Synology NAS. When I use Lightroom Classic from my desktop to synchronize the folder containing these photos, none of the metadata from my edits on my laptop is reflected when I access these photos from my desktop. What am I missing?

\$\endgroup\$

2 Answers 2

0
\$\begingroup\$

I think you need to be sure that the "Edit -> Catalog Settings -> Metadata" has the "Include Develop settings..." and "Automatically write changes into XMP" options checked.

If you're using Lightroom to move the files it will also automatically move the XMP files as well.

\$\endgroup\$
1
  • \$\begingroup\$ that worked, thanks! I checked that option, which triggered Lightroom to start writing all changes from my laptop into the XMP files on my NAS. I was a little worried that this would wipe out the photos I edited from my desktop, but it updated the XMP files for only the photos that I edited on my laptop. The only thing this didn't propagate from my laptop to the NAS was virtual copies that I created. \$\endgroup\$
    – thatguy
    Oct 17, 2023 at 0:17
0
\$\begingroup\$

You really should be using LR's export/import catalogue functions rather than moving files and syncing folders. It is the native/intended way to transfer the data between the catalogues/computers, and it should sync/include everything.

Additional XMP files are not required.

Here's a good Youtube Video about how to use LRC on multiple computers...

\$\endgroup\$
1
  • \$\begingroup\$ Steven, thanks that worked, and syncs everything. I've also disabled writing changes to XMP to save time when editing photos. What I did discover is that LR fails to import from a catalog that resides on your NAS, but once I copy the catalog to my desktop, I'm able to import that catalog, and it works like a charm. \$\endgroup\$
    – thatguy
    Oct 18, 2023 at 0:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.