In my catalog, many photos that were imported as RAW+JPG.

Note that I obscure JPGs in Library View (the default) to simplify my workflow.

In order to export my Lightroom keywords, I have just enabled "Automatically Write Changes Into XMP" in settings.


I would now like to do two things:

  1. [solved by manual XMP generation] generate XMP sidecars for existing RAW images
  2. embed the XMP in exising camera JPG images

How can I do (2)?


1 Answer 1


XMP changes (edits) are always written into jpegs (and tiffs), it never creates a sidecar file. And you would not want to apply the same edits from the raw file to the jpeg anyway.

What you want is to sync the metadata "keywords" across multiple images. You can do this in any library view by *first selecting an image that has been keyworded, then select all of the other images you want those keywords applied to, select the sync button, check the keywords section, and then select synchronize. This will also be written into jpegs/tiffs and not to a separate xmp sidecar file.

enter image description here

(*If you select an image w/o keywords first the keywords box will be empty, but you can add/edit the keywords if desired)

  • \$\begingroup\$ Thanks @steven-kersting! It's actually very valuable to know that this is how it would be done, since it has convinced me to stop importing camera JPGs. Unfortunately, in order to even see the associated camera JPGs (which lrc treats as a sort of side-car and doesn't display in Library View), I would have to unlink them via Preferences->General->Treat JPG as Separate. Then, given the hundreds of keyword combos, I'd need to run the sync procedure you describe on each keyword group by hand. \$\endgroup\$
    – mkk
    Aug 29, 2022 at 16:41
  • \$\begingroup\$ Basically, this just confirms that I should just maintain my bitmaps through export. The camera JPGs are primarily useful since they can be instantly shared with my phone. I'm just going to refrain from importing them in the future. \$\endgroup\$
    – mkk
    Aug 29, 2022 at 16:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.