2
\$\begingroup\$

I have a Canon 5D Mark IV with a Battery Communication Error. On switch on, an error message appears checking that you are using a genuine Canon battery, which I am, and I also have bought a new genuine battery. I understand from the Internet that this is a known problem that just occurs for no reason. There are no other faults with the camera.

I have sent it for repair and the cost has come back at £528. The camera needs 3 boards, the main board and 2 others. To me this sounds strange as in most electronic faults you have just one fault, it is most unlikely to have 2.

For instance, if your car doesn't start one morning, it could be, say, either the battery or starter motor, not both.

Anyone else sent their camera for repair? What was the faulty board(s)? How much was it to repair?

I do know that the main board is £150 and the service cost is £220, so the rest of the cost is because of the 2 other boards.

\$\endgroup\$
4
  • \$\begingroup\$ Not an answer, but you might read Unauthorized Bread, arstechnica.com/gaming/2020/01/… , about others who've suffered similar plights (fictional?). \$\endgroup\$ Jun 22, 2022 at 23:10
  • 1
    \$\begingroup\$ Depending on where you bought it, that "new genuine" battery might not be as genuine as you think. There are a LOT of counterfeit batteries floating around with the Canon logo on them. \$\endgroup\$
    – Michael C
    Jun 23, 2022 at 9:10
  • \$\begingroup\$ What is the exact message? Did you make sure the battery is really genuine? If yes, how? What is the history behind it? Was it working before and started to display this message suddently? etc. \$\endgroup\$
    – MrUpsidown
    Jun 23, 2022 at 13:39
  • 1
    \$\begingroup\$ It was bought from a Canon authorised dealer so I can only assume it was genuine. The camera worked perfectly fine, the only issue was the Battery Communication error. The error is "Battery Communication Error. Does this battery display the canon logo" \$\endgroup\$ Jun 23, 2022 at 16:20

1 Answer 1

1
\$\begingroup\$

I've never seen failures with real Canon batteries in the body itself, but Canon's grips are notorious for this problem. Loosening the grip a little and retightening it will typically fix the problem is that's the issue.

Another thing that can cause this failure is cheap batteries with fake ID chips. As best I can tell (and this is mostly speculation), they don't work correctly if they lose power; when the battery gets too low, the chips crash and don't ever start working again. But that wouldn't cause future failures.

I agree that three boards sounds seriously suspicious, like they tried replacing one thing, it didn't work, they tried something else, and they got it right on the third try. But without having access to the working and supposedly defective boards, there's no way to confirm that suspicion.

I would insist on getting back the defective parts.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.