0

I have a Canon 5D Mk 4 with a Battery Communication Error. On switch on an error message appears checking that you are using a genuine Canon battery, which I am, and I have also bought a new genuine battery. I understand from this internet that this is know problem that just occurs for no reason. There are no other faults with the camera.

I have sent it for repair and the cost has come back at £528. The camera needs 3 boards, the main board and 2 others. To me this sounds strange as in most electronic faults you have just one fault, most unlikely is 2.

For instance, if your car doesn't start one morning, it say either the battery or starter motor, not both.

Anyone else sent there camera for repair? What was the faulty board(s)? How much was it to repair?

I do know that main board is £150, the service cost is £220, so the rest is taken by the 2 other boards.

BTW, sorry if this is a duplicate, but the post of yesterday didn't appear.

New contributor
Robert 12345 is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
4
  • Not an answer, but you might read Unauthorized Bread, arstechnica.com/gaming/2020/01/… , about others who've suffered similar plights (fictional?). yesterday
  • Depending on where you bought it, that "new genuine" battery might not be as genuine as you think. There are a LOT of counterfeit batteries floating around with the Canon logo on them.
    – Michael C
    yesterday
  • What is the exact message? Did you make sure the battery is really genuine? If yes, how? What is the history behind it? Was it working before and started to display this message suddently? etc.
    – MrUpsidown
    yesterday
  • It was bought from a Canon authorised dealer so I can only assume it was genuine. The camera worked perfectly fine, the only issue was the Battery Communication error. The error is "Battery Communication Error. Does this battery display the canon logo" yesterday

2 Answers 2

0

I've never seen failures with real Canon batteries in the body itself, but Canon's grips are notorious for this problem. Loosening the grip a little and retightening it will typically fix the problem is that's the issue.

Another thing that can cause this failure is cheap batteries with fake ID chips. As best I can tell (and this is mostly speculation), they don't work correctly if they lose power; when the battery gets too low, the chips crash and don't ever start working again. But that wouldn't cause future failures.

I agree that three boards sounds seriously suspicious, like they tried replacing one thing, it didn't work, they tried something else, and they got it right on the third try. But without having access to the working and supposedly defective boards, there's no way to confirm that suspicion.

I would insist on getting back the defective parts.

0

Thank you for the reply. I too question 3 boards being replaced. I have asked the canon approved facility for the reasons why.

New contributor
Robert 12345 is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

Robert 12345 is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.