0

All my photos are in one directory tree:

pics/
  |--<timestamp>-<name>/  # contains exported jpgs/heifs
  |        |-- raw/       # contains RAWS & SOOCs

After I'm done with modifying the RAWs, I'll delete the SOOCs. I'd like DigiKam to only work with jpgs/heifs (because the RAWs are not meant for "viewing pleasure"). How can I tell DigiKam to "not import"/"ignore" RAW files? Neither do I want to search those, nor do I want any face detection to be run on them.

1 Answer 1

0

Searching for "digikam ignore folder" on the web I found a blog post with a tip on how to disable file types in digikam:

Choose Settings →View digiKam and switch to the MIME Types section. To exclude, for example, the PPM format, enter -ppm in the Image Files field.

In your case you would enter the file extension of your RAW files (e.g. CR2 or DNG).

Also note the warning in the blog post (bolding mine):

Excluding specific formats from digiKam doesn’t actually delete them, but simply hides them from digiKam and removes all metadata from the digiKam databases. So be careful when using exclusion filters if you don’t want to lose tags, ratings, and other metadata.

The MIME Types functionality is also mention on page 112 of the manual.

I don't use digikam myself, I just found this information on Google, so I cannot guarantee this works.

3
  • I found this blog post as well. Sadly it's from 2011 and DigiKam does not have a group "MIME-Type" in its settings now.
    – IdleMaster
    Jan 12 at 7:59
  • har! It's now located under settings / views / mime types! Thanks for the hint (the online-manual was not searchable and I wasn't aware of the PDF version existing).
    – IdleMaster
    Jan 12 at 8:07
  • "I found this blog post as well" ... and that's why it's always asked that you include your research in your question. That saves volunteers time in re-iterating unhelpful advice. Jan 12 at 10:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.