Today I got a Commlite T320 remote trigger system which I want to use to trigger my second camera that will be positioned behind a goal in football matches… I have never used a remote camera trigger system before but have used one for remote flash work and I have seen a lot of videos about them and I understand how they work(or at least I think I do lol)…

My main body is a Canon 7D Mark II and for the second/remote body I picked up a cheap Canon 700D (Rebel T5i) which will be good enough and won't be a huge money loss if a ball hits it and destroys it...

Now I placed the transmitter in the hot shoe on my main body and the receiver in the hot shoe on the second body and connected the receiver with the included cable. I set them to the same channel and pressed the TEST button on the transmitter and it worked…the second camera took a picture. Great!

Now here is my problem…when I press the shutter button on my main camera the second camera doesn't trigger…the light flashes on the receiver but nothing else happens…anyone has any idea what I'm doing wrong? Have I forgotten to change some settings?

My hot shoe was on and the transmitter was getting the signal, since it blinked a light and the receiver also blinked when I pressed the shutter button.

Addendum: When I switched the receiver's cable from the Camera port to the Flash port it started working…really weird, I know.

3 Answers 3


I'd check whether your flash is set to On or Off on the 7D Mk II. If the hotshoe is turned off, then basically the transmitter's not getting any firing signal from the camera.

Maybe also check that you used the correct sync port on the receiver for a camera shutter, and not the one for flash triggering.

That, or the trigger simply isn't designed to be used on a camera hotshoe that way. Most of these low-cost manual triggers assume that you're only going to be using one camera, where the transmitter is used in hand with the test button as your remote shutter release, or it's used on the hotshoe as flash transmitter. Not on a hotshoe as shutter remote to another camera.


The Commlite T320 triggers "autosense" if you're using them for wireless flash or remote shutter. What's probably going on is that the transmitter switches to "flash" mode if it senses it's on a hotshoe, and "shutter" if it doesn't. And then the receiver correspondingly fires from the corresponding "camera" or "flash" port. Given that your transmitter is on a camera hotshoe that could explain why the "flash" sync port on the receiver works for you, while the (logical) "camera" port does not.

  • My hot shoe was on and the transmitter was getting the signal, since it blinked a light and the receiver also blinked when i pressed the shutter button... Well your anwser was closest to the solution to my problem... on the Rx I had the cable in Camera port... and when i switched it to Flash port it started workinng... realy weird... i know
    – weinde
    Jul 7, 2021 at 9:04
  • @weinde, Adding an edit to both the Q and my A based on that information.
    – inkista
    Jul 7, 2021 at 18:23

Have you checked the auto power-off setting on the secondary camera (the T5i)?

When my Rebel T7 turns off after the timeout, it takes a second or two for it to "wake up" when I half-press the shutter (or press any other button). If the camera is in auto-off and I fully depress the shutter without waiting for it to wake up, it does not take a photo. I suspect this is what's happening with your remote trigger -- it attempts to fire the shutter immediately upon receiving the signal, but since the camera is in auto-off, it isn't able to take the photo.

On my camera, this setting is labelled "Auto power off" and is found under the first yellow wrench of the settings menu. Try setting it to "Disable".

Note that this will likely impact your battery life. Since you're intending to operate the camera remotely, you can adjust other options to conserve battery, such as turning off the display and disabling image review.

As a side note, you may want to cover the eyepiece on the secondary camera, since light entering through the viewfinder can affect the light meter and confuse the auto exposure. Ordinarily your face is there to block the light, but since you're across the field you'll need to use something else :) The neck strap of my T7 came with a little rubber piece that's designed to cover the eyepiece in this type of situation. This Canon page describes how to remove the eyecup and attach the eyepiece cover.

  • 1
    hey thanks for your reply. I will definelty change some settign you mentioned :) but the solution to my problem was relay something else :) anyway thanks man!
    – weinde
    Jul 7, 2021 at 9:07

If you are photographing live action sports, the shutter speed is likely to be above the flash sync speed and therefore not trigger the hot shoe circuit.

Of course I could be wrong.

But you can eliminate this as the problem by lowering the shutter speed below the sync speed and testing the system.

If that’s not the problem, see if you can trigger a flash remotely using the on-camera trigger you are testing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.