3
\$\begingroup\$

I recently bought a Canon 7D, upgrading from a 50D. I was blown away by what I saw on the back of the camera after I took a few shots.

Now that i've taken the time to import the photos into lightroom & DXO... I'm finding the noise level to be very high, even on low ISO shots I find myself dealing with much more noise than I'm used to.

Has anyone experienced this? Are there any solutions?

I've had this camera for two days and I'm already thinking of selling it... if I can't find a solution for all this noise.

Edit: After some discussions, and comparisons, jpg files rendered by the body look great. I'll just have to get used to post processing a bit more.

I also found out that for the best results use multiples of 160 ISO. (I need to test this)

\$\endgroup\$
6
  • 2
    \$\begingroup\$ I can't say that I've ever had serious noise issues with my 7D... Which leans me towards 1 of 3 thoughts with what's going on (in order of most likely to least likely): 1: User error, 2: Unreasonably nit-picky user, or 3: Broken camera... Most of the time I hear this complaint with my students we end up narrowing things down to #1. Any chance you'd be willing to post a picture or two showing the noise problem you're having? \$\endgroup\$ Commented May 27, 2011 at 6:08
  • 11
    \$\begingroup\$ Can you post an example image? That would make it easier to answer the question. \$\endgroup\$
    – Matt Grum
    Commented May 27, 2011 at 7:31
  • \$\begingroup\$ preferably with a comparable example shot from the 50D (exact same shot/settings if you still have it? or at least something close from the archives) \$\endgroup\$ Commented May 27, 2011 at 7:56
  • 3
    \$\begingroup\$ Also, are you comparing pixel to pixel or accounting for the higher resolution of the 7D and viewing at a specific magnification of the full image? (7D has more per-pixel noise, but should have less noise at the same magnification/scale) \$\endgroup\$ Commented May 27, 2011 at 8:00
  • 4
    \$\begingroup\$ On the edit: there is no grain in digital photographs. Posting a sample would really help. \$\endgroup\$
    – mattdm
    Commented May 27, 2011 at 12:57

2 Answers 2

9
\$\begingroup\$

Because of the pixel density I would say. Your 50D had the highest pixel density in Canon's lineup when it was released, at 4.5MP/cm2. At that density the lens becomes the limiting factor, you need good glass. A few reviews pointed out that the image quality of the 50D wasn't much better than the 40D it was replacing actually, with a density of 3.1 MP/cm2. This is even more true for the 7D, which topped the 50D with a 5.4 MP/cm² density. For reference, the full frame Canon 5D II is at 2.4 MP/cm2.

From a theoretical point of view pixel density should affect the amount of random digital noise and the dynamic range in the image the camera produces. Granted, a lot is going on under the hood in the 7D to reduce/fix this "limitation", but that could be why you feel there is more noise in your 7D than in your 50D.

I have a 5DMII. Friend of mine bought a 7D. We tested in a room I had used my 5DMII in, and I was surprised by the noise myself, it didn't have the same "quality" as what I would see on the 5DMII. Granted, we should have put my L lens on his 7D, instead of his kit lens. He sold it to buy a 5DMII.

\$\endgroup\$
8
  • \$\begingroup\$ I currently shoot with 70-200mm f2.8 IS (version 1) , 17-55mm f2.8 is and 50mm f1.4. I agree that glass does make a difference. I will try different conditions this weekend and post some test shots. I already sold my 50D so I won't be able to compare properly. \$\endgroup\$ Commented May 27, 2011 at 20:10
  • 1
    \$\begingroup\$ I got rid of my 7D within months of buying it as the noise was just no good for what I shoot. It does ok at higher ISO as you are expecting a lot of noise and it seems to do better than you might expect but the ISO100 noise levels are just unacceptable when you see the cleaner images produced by other bodies \$\endgroup\$
    – JamWheel
    Commented May 27, 2011 at 21:59
  • \$\begingroup\$ @JamWheel what was your alternative ? \$\endgroup\$ Commented May 28, 2011 at 2:03
  • \$\begingroup\$ @Alexandre I ended up with a 1D MkIV lol \$\endgroup\$
    – JamWheel
    Commented May 29, 2011 at 4:59
  • \$\begingroup\$ @JamWheel I doin't think I will be going to that extreme =) I will be going to the store today to show them images that have random white lines in them and to try and get a replacement body. \$\endgroup\$ Commented May 30, 2011 at 13:39
1
\$\begingroup\$

The "native" ISO of the Canon 7D is supposed to be 160, that's on this that you'll get your best results. I have a 60D myself and I have often to post process my pics for noise =)

\$\endgroup\$
2
  • \$\begingroup\$ Hmm. Can you back up the claim about the native ISO? I don't know one way or another, but found this to the contrary: shootintheshot.joshsilfen.com/2010/05/13/… \$\endgroup\$
    – mattdm
    Commented Oct 1, 2011 at 1:31
  • \$\begingroup\$ Like the article said, it's probably a misconception that I had :/ Thanks for the info =) \$\endgroup\$
    – mdcarter
    Commented Oct 13, 2011 at 21:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.