When I open a picture (it's a JPEG, as I was shooting a timelapse and didn't want it to take too much space), any edits are discarded if I try to compress the history stack or if I leave the picture and ho back to photo list.

If I try to create a template from the edits it will tell me that it cannot make a preset from an unchanged picture.

I tried to delete all the .xmp files, but that had no effect.

Here is a video of what I am experiencing: https://youtu.be/m6ftvB9c7B4

Why is this happening?

2 Answers 2


I tried to delete the pictures also from the database and it still didn't help. @sebix was right when he commented that the basic modules are missing, they should be there.

In the end, I gave up. I deleted all darktable databases and installed the latest version. It solved the problem.


Which darktable version are you using, on which OS?

You did not select the button to compress the history stack, but to create new style from the stack. And for that, you got an error message "can't create style out of unaltered image".

When compressing, the all history items up to the selected one are compressed. Those above the selected item are discarded.

I am also wondering why you don't have all the basic module enable/visible in the history stack (input color profile, output color profile, display encoding, sharpen, orientation).

  • I don't have these modules in stack because I am editing JPG. The problem with compressing the history stack is not in the video I made, but it happens. And the image in the video IS altered, yet darktable acts as if it wasn't. May 2, 2021 at 18:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.