7

I've noticed on several occasions that the colors of my photos are slightly off when uploaded to Facebook. But I noticed this apparently is only in Firefox.

Take this photo, for example: https://www.facebook.com/stroiman.photography/photos/a.119725813405108/144011940976495

When viewed in Firefox (macOS), the colors are off. Most noticeably in the bottom of the picture, where the rock is too red and saturated. When viewing the page on Chrome or Safari, the colors looks correct*.

I also uploaded the same photo to 500px, where the colors look correct* in Firefox: https://500px.com/photo/1030535577/the-red-waterfall-by-peter-stroiman

When the colors look correct in 500px, then my conclusion must be that it is not me doing something wrong. Although I edit the photos in ProPhoto or ROMM RGB, I always export to sRGB color space from inside Capture One.

I read somewhere that Facebook compresses the image into a proprietary ICC profile as a means to save kB, so this probably relates to Firefox doing color management different from other browsers (unfortunately, I didn't save the link to that page).

Is there anything I can do, e.g. export to a different ICC profile for Facebook to make sure that colors are rendered correctly in all browsers? It annoys me that users of a particular browser does not see the images as they were intended, and in this particular case looks over-processed.

* By "Looking correct", I based this on a visual inspection with the browser and Capture One side to side.

Edit: As reference, this is the original file I uploaded to Facebook: http://stroiman.com/Red%20waterfall_facebook.jpg

0
8

According to ICC color correction in Firefox, Firefox has been capable of reading colour profiles in images since Firefox version 3 (released 17 June, 2008). This was configurable, and initially defaulted to 'off', but this default behaviour was changed to 'on' in Firefox 3.5 (released 30 June, 2009).

However, this comes with a big caveat. It seems ICC profiles come in two versions, and Firefox only reads the older version by default. Quoting Wikipedia, "Two main generations are used: the legacy ICCv2 and the December 2001 ICCv4. Since late 2010, the current version of the format specification (ICC.1) is 4.3."

There is a configuration setting to get Firefox to read ICCv4 profiles. To enable this, enter about:config in the navigation bar, and search for and change the setting gfx.color_management.enablev4.

As mentioned by the OP, this is all well and good for your own browsing experience, but it's quite unlikely that other Firefox users will have gone and fixed this configuration themselves. It looks like there is some ongoing work to address this by Firefox developers, but since the linked bug is 13 years old and still open, I wouldn't hold your breath. If you want to fix this yourself for all Firefox users, here's how to contribute to the Firefox code base: https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Introduction

1
  • As your answer seems to be outstripping mine, for sake of completeness I'd add the point that leaving gfx.color_management.mode at 2 won't fix the issue for untagged images. You need to set it to 1 to fix the Facebook page. [I just tested empirically]. – Tetsujin Apr 5 at 8:07
2

A bit of Googling finds that colour management is switched off by default in Firefox [I'm not even going to comment on what I think of that idea;)

To enable it...

  1. type about:config in the address bar & hit Enter.
  2. It warns you you're going into some 'advanced' mode, accept.
  3. Type gfx in the search bar that appears.
  4. Scroll down until you find gfx.color_management.enablev4 & click the icon to the right to set it to true
  5. Below that, set gfx.color_management.mode to 1 by clicking on the pencil icon
  6. Leave force srgb at false & rendering intent at 0

You should end up with this…

enter image description here

Quit & relaunch.

Tadaahhh!

Essentially, using those settings means it will use the embedded profile if there is one, or assume sRGB if there isn't - which is about as sensible as you can get for untagged files.

From comments
I can't test this absolutely 'fresh' on Mac as I have had Firefox installed for a long time - though I have never really used it & certainly never set up management before - so I'd think off is default.
On Windows 10 with a brand new install, never before seen on that machine - default is definitely off.

11
  • 2
    Thanks. It does make the pictures look correct. However doesn't really solve the problem as it now looks correctly on just my computer. I'm more concerned about how it looks when other people see my images. And I can only assume that all but a very few of the Firefox users have not changed this setting. Maybe I should file a bug report with Firefox? Strange that this is not the default setting – Pete Apr 4 at 11:22
  • I honestly cannot figure out why anyone would make this the default. As there's nothing you can do to prevent online services removing metadata, nor anything other users do in viewing your images, you're kind of stuck with it unless you can persuade Mozilla to fix it. You could watermark everything with 'best not viewed in Firefox'… but I don't think that's a great solution ;)) – Tetsujin Apr 4 at 11:27
  • Well, is it switched off by default? Not according to this page: ICC color correction in Firefox – osullic Apr 4 at 11:54
  • I found that page on my travels - but it refers to FF 3.5 - I've no clue what v3.5 is, mine is v87. It was off on my install [untouched since the day I first tried it & put it away again as 'not the browser for me'] & was off on the OP's version too. edit: Looking one level up from that page developer.mozilla.org/en-US/docs/Mozilla/Firefox/Releases really does look that's from 80 versions ago. – Tetsujin Apr 4 at 12:00
  • 1
    @Tetsujin Firefox started off with very slow incremental releases - it crawled from version 1 to 2 to 3 up to 4. Once it hit version 4, they started smashing out new releases at a feverish pace. I use FF as my daily browser, and my gfx.color_management.mode setting is 2 as expected. That document says that the setting to support colour profiles has defaulted to 'on' since FF3.5 (released 30 June 2009). – osullic Apr 4 at 12:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.