1

I recently bought a used Canon 6D with the 24-105 f/4 L USM kit lens. After shooting some outdoor pictures at night, I noticed some colored pixels or dots in the images, especially at longer exposures (10-30s). I have made some test shots with the lens cap attached to show these dots (the area stays the same):

ISO 2000, 30s: enter image description here

ISO 500, 30s: enter image description here

ISO 500, 15s: enter image description here

ISO 500, 5s: enter image description here

ISO 500, 1s: enter image description here

I have also looked at the following posts:

From what I'm gathering this is most likely some kind of noise (may thermal?) due to the long exposure, but this doesn't look like the usual noise I've seen before with higher ISO values. Could these dots be stuck pixels?

4
  • Check this answer: photo.stackexchange.com/a/50231/34947 part about hot pixels Feb 25 at 16:01
  • Ok, thanks for the link. I've tried the hot pixel fix "trick" out where the mirror is to be placed into manual cleaning for a certain amount of time, and it seems to have worked, at least for some of those pixels. I was thinking about sending the camera to Canon for a full service with pixel remapping, but I'm still hesitant as this will cost about 170€.
    – ADDelta
    Feb 26 at 13:06
  • Hmm, that seems like a good idea, I'll try the "black picture after a long exposure" technique out as soon as the moon isn't so bright again. In the meantime I've taken some pictures during the day and everything looked good, which is a great comfort to me.
    – ADDelta
    Mar 3 at 23:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.