2

I recently purchased a used Sigma 105mm f2.8 DG OS Macro lens, and when I tested it during the purchase everything worked fine. A few hours later when I tried it again, I noticed that my pictures were really overexposed at anything other than f2.8 (the min is f22).

I detached and reattached the lens, and then all my pictures were fine again, properly exposed, and I verified that the aperture blades were indeed working. I turned the camera off and on and it was still fine. A few hours later, I tried again, and the pictures were again overexposed aside from f2.8, and the blades were not moving.

I've been able to replicate this several times now, and I'm not sure what could be causing this - the blades are not oily, and they clearly work for a period of time after the lens is attached.

For reference, I have a Canon EOS M50, with a third party adapter for non-M-series lenses. The adapter works great for the other non-M-series lenses I own (one Canon lens and one Yonguo). Something peculiar I noticed is that the Sigma lens is very difficult to attach and take off compared to my other two lenses, I really have to give it a good twist when adding/removing it from the adapter.

Any insights or advice would be greatly appreciated!

3
  • Do the blades close when the camera is trying to measure the exposure? They probably do, otherwise the camera wouldn't overexpose the image, right? – rauberdaniel Jan 1 at 12:52
  • 1
    Check for a loose/bent mounting ring... I suspect it's weak electrical contact due to difficulty attaching the lens. – Steven Kersting Jan 1 at 14:41
  • 1
    @rauberdaniel The camera does not measure exposure, it has a light meter that measures the light and then tells the camera, and the user, what settings are required to get the proper exposure. Aperture blades do not close when the light meter is reading light, if they did then that would restrict some of the light and give a false reading. The camera, or the user, reads the settings supplied by the light meter and uses those setting to make an exposure I.E. Closes the blades when the shutter is released to the Fstop that is set. This problem appears to be a communication error. – Alaska Man Jan 1 at 21:51
1

It sounds like you have a bad connection, an incompatible connection or a bad lens. Clean the contacts on the lens and camera and coupler. If it persists, try the lens on an EOS EF mount body. If it still happens you have a bad lens. I suspect that it's the coupler.

1

After doing some research (this thread being a particularly useful one: https://www.dpreview.com/forums/thread/4392551), it seems that certain Sigma lenses are incompatible with newer Canon models like the M50. You'll either have to wait for a firmware update (if they offer one), sell the lens, or wait until you get a new body (check to make sure it works beforehand).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.