I have an old analog MAMIYA camera. I'm not sure about the exact model as it is not listed anywhere on the device (picture included). Recently the mirror started sticking in the up position occasionally. It's usually fixed by pulling the loading arm and letting it flick back. picture

I've found some similar issues online. It's often stated that a foam ring around the focus window is too sticky. Unfortunately, my device doesn't have this ring.

After finicking about everything seems to work properly now, but I can bet the thing will jam again as soon as I put a new roll in it.

A local camera salesman said there could be some sticky things inside the mechanism but couldn't give me any details.

I am not too afraid to open the thing up and inspect the insides as similar cameras go for about €20,- (so ruining it would not be the end of the world). I would like to know what to look for before doing so though.

Any ideas about where this problem could arise from?

Edit: Did a google. The model seems to be a 1964 MAMIYA PRISMAT CP (probably)

  • \$\begingroup\$ To get an idea of what’s likely to be involved with a repair, it might be worth watching some camera repair videos before opening your camera up. I like Fix Old Cameras youtube.com/c/FixOldCameras \$\endgroup\$ Commented Dec 2, 2020 at 2:40
  • \$\begingroup\$ @benrudgers Thanks for the advice. I found a fix on the channel, though it is another camera. It seems to be as simple as giving it a drop of oil. \$\endgroup\$
    – iHnR
    Commented Dec 2, 2020 at 13:22
  • \$\begingroup\$ It'll make for a nice project! Good luck. However, make sure to use the tiniest amount of oil possible (and to use whatever specific kind of oil/lubricant that the repair experts recommend). I talk from bitter experience, having once ruined a Minolta XD5 by being a bit too liberal with the oil (was trying to fix a stuck self-timer). It still leaks through the shutter blades... \$\endgroup\$
    – Kahovius
    Commented Dec 2, 2020 at 14:39
  • \$\begingroup\$ @Kahovius Fix old cameras seems to use sewing machine oil. Sparingly. Very sparingly. \$\endgroup\$ Commented Dec 2, 2020 at 15:39

1 Answer 1


So turns out my guesses were completely wrong. I did end up opening the camera and putting some drops of oil in recommended places, which didn't end up solving the issue.

However, during this process I removed the battery for the built in light meter. The original 1.3V battery is not really available anymore but I found out that a standard 1.4V hearing aid battery works quite well. they're also quite cheap. This battery happens to be just slightly thicker though. What I found out was that the mechanism suddenly worked perfectly when the battery was removed. Moreover it stopped working again when I applied light pressure to the bottom of the battery compartment. The pressure must be blocking some mechanism behind it just enough to be unreliable.

The issue was finally solved by dremeling the plastic on the back of of the battery compartment to be a bit thinner. I also made sure not to screw on the battery cap too tight.

Not sure if this is going to help anyone, but there it is. I know some others use the same batteries for old cameras, so it must happen more often.

  • \$\begingroup\$ Nice! A little outside the box, but certainly easier/cheaper than a full CLA. \$\endgroup\$
    – Zeiss Ikon
    Commented Jan 11, 2021 at 13:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.