2
\$\begingroup\$

So I've spent the entire afternoon trying to get EOS Utility to detect my 60D without breakthrough and I'm desperate for help!

What I have done so far:

  • Updated anything that could be updated on my computer
  • Restarted many times
  • Uninstalled and reinstalled EOS Utility 2 and 3 and any other canon software
  • Tried all the USB ports on my computer (over 20)
  • Tried 2 different cables
  • Tested the cables and SD cards in an T7i with success (was able to connect to EOS Utility 3 and offload my pictures that way)
  • Updated the camera's firmware
  • I'm on windows 10 64 bit so I uninstalled the camera through Device Manager

I'm out of ideas at this point... It worked last week if you can beleive it, and I changed nothing to the setup since! I really like that my pictures gets automatically sorted by dates and that it's noted that the pictures were transfered at least once. I know I can just throw the SD card in the reader and call it a day but I enjoy my things working as intedted and as usual!

Update:

I was able to get my hands on a second windows 10 computer that already had a known working EOS utility 2 (a laptop from work) and connecting the 60D to this laptop was detected correctly and I was able to use the software as usual. This probably means a deeper problem than eighter the camera, cable, usb controller or software. Perhaps a registry error of some kind.

I'll keep this post up to date if I ever get to fix this without a fresh Windows 10 install...

Update:

I've found some Canon documentation that recommended to restart after uninstalling EOS Utility software, so I did. Afterward, I did a c:/ drive search for "canon", and removed everything that was Canon related. I also cleaned up the registry of any traces of "Canon" or "EOS" including the device cache for my camera... Or at least until I was sick of it because noting relevent came up after a while. Afterward, I restarted again. Re-installed the EOS Utilities. Restarted again. And... Nothing, still don't work. I cannot make heads or tail of this issue and now I am truely out of resources...

Please, if someone out there knows this issue's solution, help!

\$\endgroup\$
8
  • \$\begingroup\$ Can Windows download photos when cabled? \$\endgroup\$ Nov 29, 2020 at 21:44
  • \$\begingroup\$ Yes, I can browser the SD card through the device in Devices and Printers \$\endgroup\$ Nov 29, 2020 at 21:46
  • \$\begingroup\$ Normally I would suspect that the USB cable is a "charging" cable (no data pins) but you say this works with the T7i. Have you applied the EOS Utility Updater (2.14.20a)? See: usa.canon.com/internet/portal/us/home/support/details/cameras/… \$\endgroup\$ Nov 30, 2020 at 4:34
  • 2
    \$\begingroup\$ @TimCampbell That update was issued in 2015. Since the OP says it was previously working, I doubt that's the issue. \$\endgroup\$
    – Michael C
    Nov 30, 2020 at 9:20
  • 1
    \$\begingroup\$ Updated the post with some new info \$\endgroup\$ Dec 2, 2020 at 17:04

1 Answer 1

1
\$\begingroup\$

I removed all the Utilies software completely, and reinstalled the Utilies v2.9 from the CD which came with the EOS 60D camera. It now works! The lesson is, don’t install any of the Utilies software updates. Just stick with the CD software. If it ain’t broke, don’t fix it!

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.