3
\$\begingroup\$

I am having lots of trouble with my Neewer 750 II flash. I attached it to my Nikon D750 and the red light was pulsing, but later it just stayed fixed and the pilot button is not working either. I am not sure if it's an internal problem or my camera settings (I am new to flash so I am not sure how it is supposed to be).

A few months ago I used it in TTL and it worked just fine, but right now I've tried several options, including resetting my camera settings, resetting my flash settings, silent mode, changing my shutter speed, but nothing.

The flash seems to be communicating with my camera because all the info from it is reflected on the flash screen, but I don't know what else to try.

Any suggestion?

\$\endgroup\$
6
  • \$\begingroup\$ Do you have your shutter speed set to sync speed or lower? Do you know what the sync speed is for your camera? If you add your camera model it may help to get an informed answer. \$\endgroup\$
    – Alaska Man
    Nov 28, 2020 at 22:11
  • 1
    \$\begingroup\$ A long period of flashing red strongly suggests that the first test is to try other batteries to make certain you have fresh batteries. \$\endgroup\$
    – WayneF
    Nov 29, 2020 at 3:34
  • \$\begingroup\$ Hello Alaska! I have no idea what's my sync speed. My camera is a Nikon D750. Can you help me please? \$\endgroup\$ Nov 29, 2020 at 3:35
  • \$\begingroup\$ Hello Wayne! I bought 8 new batteries. At the beginning it seemed this resolved the problem, but later it kinda flashed whenever it wanted. So maybe it has to do with my settings? But honestly, I am not sure what I should change. I have a Nikon D750. \$\endgroup\$ Nov 29, 2020 at 3:36
  • \$\begingroup\$ Irregular flashing is Not about sync speed, but your D750 is 1/250 sec maximum. Make sure your flash foot and flash shoe are clean, brush them with something like an old toothbrush. Be sure the flash is fully seated deep in the shoe. Make sure flash is NOT in a slave mode S1 or S2. \$\endgroup\$
    – WayneF
    Nov 29, 2020 at 4:15

1 Answer 1

1
\$\begingroup\$

Nikon changed the hotshoe on the D750 (and later models), making it slightly too deep for a lot of 3rd party flashes to fit perfectly if the foot is pushed all the way forward. If you push a 3rd-party flash or transmitter foot all the way into the hotshoe, the TTL/HSS pins can lose contact and camera/flash communication can be wonky or not happen at all.

The basic hack to fix this is to:

  1. Seat the flash full forward in the hotshoe.

  2. Partially lock down the foot of the flash.

  3. Slowly pull the flash foot back until you hear the locking pin click into place into its hole in the hotshoe.

  4. Finish tightening down the foot on the hotshoe.

Alternatively, build a spacer for your hotshoe.

See also this f-stoppers article on the issue:

https://fstoppers.com/originals/stop-fighting-hot-shoe-your-nikon-d750-110295

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.