2

I’ve been working on a colourful image but when I export it to jpeg, the colours are almost gone. Sure, I understand saving in jpeg can lead to change in colour but.. this is the most massive loss of saturation I’ve seen. The same thing happens if I merge down as well.

This is what my layers look like

enter image description here

Am I missing something obvious?

The difference:

left is the file still in PS and right is my jpeg

The purple colour especially seems to not appear. I feel like I'm missing something obvious. Am i working in the wrong colour space?

How can I get the colours to pop in my export files?

New contributor
Akr is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • 1
    If it fades just by flattening the image (still in Photoshop), then it has nothing to do with jpeg and with saving as such. But I'd struggle to explain such behaviour. – Zeus Nov 20 at 6:52
  • 2
    I’m voting to close this question as it would probably be a better fit for graphicdesign.stackexchange.com It actually has nothing to do with photography. – Tetsujin Nov 20 at 12:17
  • 3
    This can/does affect editing of photographs as well IME. So I gave an answer instead of voting to close. – Steven Kersting Nov 20 at 17:35
3

It is due to the way PS flattens an image; by default it (sometimes?) preserves the layer masks; and the underlying layer's mask will mask the layer above. If you attempt to merge/flatten only two layers PS will pop up a warning about this; and it gives you an option of applying the mask of the underlying layer before merging. You do not get the option when you export, flatten a group of layers, or flatten the entire layer stack.

The behavior also seems to be dependent on what is being flattened/merged e.g. adjustment/vector layers vs image layers (or if an image layer is included). I can't really say for certain exactly when it will/won't happen. In your case, it appears that the layer "1"s mask is masking some/all of the edits above it...

The way I have found to get around it is to create a new top layer and then merge visible into it (shift-opt-cmd-E). This copies the current view as a new image on top of all other layers; then turn off all other layers below before exporting/flattening (alt/option click on the top layer's view (eye) button). Your result should then be what you were expecting.

| improve this answer | |

Your Answer

Akr is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.