I'm trying to print an image on plain paper with an Epson SC-P800 printer using GIMP 2.10 on MacOS 10.14.6 (Mojave). I can find no setting in the print or page-setup dialogs to set which black ink is used. When I attempt to print the printer is prompting me to switch to Photo Black.

Has anyone made this work?

  • \$\begingroup\$ Why does it matter? If using black instead is really critical to your work have you considered exporting from Gimp and printing with a different application that provides better printer support? Does your image fit within the gamut that black produces? \$\endgroup\$ Nov 19, 2020 at 3:54
  • 1
    \$\begingroup\$ Generally Gimp’s printing functionality provides convenience. Fine grained control is not always possible within it. Printing is very complex and Gimp development depends on volunteers. Epson could devote engineering time to making the Gimp experience flawless when using their printers. Epson doesn’t prioritize that. \$\endgroup\$ Nov 19, 2020 at 4:00
  • \$\begingroup\$ Why wouldn't you want to use photo black ink for a photo? Photo black ink is optimized for printing photos on coated photo paper. Black pigment ink is optimized for printing text on plain uncoated paper. It's not for photos. \$\endgroup\$
    – Michael C
    Nov 19, 2020 at 6:51
  • \$\begingroup\$ Michael C - That's exactly the point. Photo Black is for coated photo paper. I'm printing on plain paper. I've told GIMP i'm printing on plain paper. I've told the print dialog (which I'm guessing is Epson code) that I"m prining on plain paper. But the printer insists on using photo black ink. ...and the only option is to cancel the print. \$\endgroup\$
    – NetFool
    Nov 19, 2020 at 20:17
  • \$\begingroup\$ Maybe I'll try installing CUPS. I used that once for a 15-foot long roll paper print on an Epson printer. Other than that, Ben Rudgers seems to have the only solution. Epson not only doesn't prioritize GIMP, they're awful at providing channels for user feedback. \$\endgroup\$
    – NetFool
    Nov 19, 2020 at 20:40


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.