1

What are the most common issues with the Godox AD200 Pro not firing all the time?

I set my channel higher as well as the ID#.

8
  • What controller are you using to fire it/them?
    – Michael C
    Jul 21 '20 at 8:59
  • Thanks so much I have set my channel higher so let's see how this works, with regards to the ID# I read that this should be kept off is this correct or should I turn this on and assign a number and if so which #. Thanks in advance
    – Al V.
    Jul 22 '20 at 4:11
  • I am using Canon gear I use the XProC.
    – Al V.
    Jul 22 '20 at 4:13
  • 1
    Does this answer your question? My Godox flash won't fire off-camera. What should I check?
    – inkista
    Jul 22 '20 at 4:15
  • I am using Canon gear I use the XProC. Update I did read the manual and it did state that this; Note: As the current Godox flashes do not have wireless ID setting functions, please set ID to OFF, I am using the AD200PRO and it does have an ID3 Function so should i set this and use the same # for both the transmitter and flash?
    – Al V.
    Jul 22 '20 at 4:20
1

Usually there are some common points that might influence the reliability of the Godox strobes:

  1. Distance - the sender has two menu options here. One setting for distant strobes and one for very close strobes. Many users report unreliable shots when using close distance to strobes when not applying the 0-n meter setting. On the Xpro trigger, e.g. go to menu -> Scroll down to dist -> set 0-30m.
  2. Battery level - although the sender seems to run fine on rechargeable batteries, some users reported unreliable function with half empty batteries or rechargeables.
  3. Interference - this can be either other devices using the same band like WIFI hotspots, which then can be helped by trying out other channels - or in some cases structural obstacles either hidden in the walls or visible.
  4. Using it too fast - the obvious thing, but sometimes even that might happen. If you are not sure, if that is the case, enable the recharge beep on the device to hear if you can take another shot.
  5. Flash bothered by itself - I had one photo session, where the flash switched back to full power from time to time. This ended after taking out the batteries and restarting the flash.
5
  • Thanks so much for your advice, I will turn on the beep on the device and see if this helps, with regards to the 0-n meter where can I find this.
    – Al V.
    Jul 22 '20 at 4:08
  • Go to menu -> Scroll down to dist -> set 0-30m Jul 22 '20 at 7:08
  • Thanks so much for your help, so I set this 0-30 changed my channel on both the transmitter and flash to #21 and it would not fire so I went into the flash function settings menu on my canon mark4 and found the Rdio Channel setting but this only goes from 1-15 so I set this to #14 as well as the other units and it fired just like before while I have not tried it to see if it misfires I was really hoping to use a higher channel, what am I doing wrong?
    – Al V.
    Jul 23 '20 at 5:27
  • @AlV. Are you sure you're not getting the group number and the channel number mixed up? They're two totally different things.
    – Michael C
    Jul 23 '20 at 9:25
  • @AlV. You shouldn't even have "wireless" turned on in the camera's menu. That's for optical wireless control using Canon's optical system, not for a third party radio system.
    – Michael C
    Jul 23 '20 at 9:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.