I've had a Canon PowerShot A1100 IS camera for almost a year now.

About a week ago, I went on a trip, took pictures the whole trip, everything was ok.

When I got home, and tried to turn the camera to move the pictures to my PC, I got an error: "Lens error, restart camera"

The lens doesn't even start to open, doesn't make any sounds of trying even.

What can I do to fix this?

  • If the problem is keeping you from moving your photos to the PC, you can remove the SD card from the camera and use a card reader to read it. If you don't have a card reader in your computer(s), they are available inexpensively, for example: amazon.com/Mini-Memory-Card-Reader-Writer/dp/B000FNDWLQ/…
    – coneslayer
    May 6, 2011 at 13:54
  • 3
    I got this issue with my camera too, when my son dropped it in the sand. The lens mechanism retraction is very fragile. One grain of sand is enough to break the camera. In our case, we got the camera for less than a week, so we returned the camera for an exchange. May 6, 2011 at 14:01

9 Answers 9


Lens errors are fairly common. Usually it's sand or grit interfering with the lens extension mechanism. Or the camera's been dropped with the lens extended. Or the camera has been powered on, but the lens had been blocked preventing its extension.

I have written a blog post about some things that you can do to try to correct it. They only seem to work for about 50% of lens errors, but they're worth a try. The list includes:

  1. Remove the batteries and wait a few minutes
  2. Try pressing and holding the Menu, Function, Function Set, or OK while turning on the camera, or otherwise find a "factory reset" option.
  3. Try turning the camera on without a memory card inserted
  4. Place the camera flat on its back and turn it on while holding down the autofocus button, to try to cause the camera to attempt autofocus while the lens is extending
  5. Blow compressed air in any gaps around the lens — or use a shop vac
  6. Use a thin piece of paper or a needle to dislodge any visible bits of grit
  7. Gently tap the camera in an attempt to realign jammed mechanics or dislodge particles (obvious warning: could cause further damage)
  8. Gently push or pull the lens barrel, as a last resort (again, potential for further damage).

The blog post goes into more detail on these ideas.

  • 2
    Welcome to Photo.SE! Your blog post seems to have helped many people, so I edited your answer to include the disclaimer required in our FAQ when linking to one's own site in hopes that your answer won't be flagged as spam.
    – Imre
    Oct 6, 2011 at 5:02
  • 1
    The link helped me. Number 7 tip eventually solved the problem (Tapping it lightly on the back a few hundred times) Oct 6, 2011 at 12:12
  • I have a Canon SD1000. One day I got the "Lens error, restart camera". I used option #7 Worked! Blew a little compressed air after to insure it cleaned out. Its fine. Thanks
    – Marinaio
    Feb 21, 2021 at 0:00

This can come up for a variety of different reasons, typically it happens after the camera is dropped. If the camera was dropped, compressed in your luggage too tight, gathered a grain of sand while on the beach, or had a similar occurrence, you can find yourself with this error message. These cameras are mostly made of plastic, and it can even happen under regular use where nothing was done wrong.

Don't fret, you have options. Some people have luck with removing and replacing the batteries multiple times, so you could try that. But if you are still within the warranty period I would do that before taking more invasive measures such as giving the lens a nice hard bump. Head over to Canon's repair website here.


I own a PowerShot A495 and recently the lens was stuck in the fully extended mode. Each time I tried to power up the camera I got "Lens Error, automatically shutting down - Restart Camera" - and it would turn off.

After visiting a number of locations on the internet, and trying a number of fixes I became desperate.

Realizing the camera was out of warranty, and the cost of repair would equal or exceed the price of the camera, I tried a desperation move.

After removing the batteries and SD card and letting the camera sit overnight, I replaced the batteries and card in the morning. I then powered on the Camera and while holding the Function/OK key and the Shutter Button, I gave the extended lens barrel a couple of face-down light taps directly on a hard desktop. I was truly ecstatic to hear the lens motor whirl and to see the lens barrel retract.


Less than a year? Cool. Send it to Canon for warranty service. The lens mechanism on compact cameras is one of the most vulnerable points, and it can get damaged even under normal use. They should fix this for free.


My Powershot S100 had a similar problem. Beep beep, "Lens Error", shut down. I definitely didn't drop it because I was holding it when it happened. And I didn't get sand in it (as far as I know). It was just a year after I bought it so Canon wouldn't fix it. Even though they have a recall notice, my serial number wasn't within the range specified on their site. I've owned several Canon's before but no luck getting any support from them after warranty is up. They do reject you very politely to their credit. If you google "lens error s100" you actually see that this error happens quite a number of times. I think that's surprising, considering this camera was $420 purchased new.

Out of desperation and abandoned by Canon, I decided to fix the thing myself. I ordered a replacement lens assembly from eBay, and a lot of little screws later I had a working s100 again. It was amazing, I felt like some kind of genius and bragged to all my friends. Unfortunately that only lasted about 2 weeks. Then, even more surprisingly, beep beep, "Lens error".

tldr; I think it's probably a great camera just made with crap parts


Seems like a similar issue to this question

As I said on there, remove the battery (batteries if it has a small watch-style one too for keeping the time etc), and leave for no less than an hour. Then put batteries back in and see how it goes. Ensure lens mechanism is clear of dirt/sand/etc...


While tapping the camera with the lens side up turn on the camera in play mode. If this doesn't work turn it on alternating between video, auto, and camera modes (while tapping). This worked for me. I had to switch to video prior to tuning it off a few times before the lens reset.


This happened to me. Put your camera upside down, screen side down. If your camera won't even begin to open, then GENTLY push the lens down where the gap is. If successful, you will hear a click. Now take out your battery, and replace it. THIS WILL WORK!!!

  • This will work in some cases.
    – mattdm
    May 18, 2014 at 17:31

Maybe there was something jammed inside the camera. Have you shaked the camera alot? If not then try to change batteries. Maybe the battery did not have the power to move the lens. If you have the confidence on this next step, when you turn on the camera, shake it hard so that the motor will get pushed and the lens should come right out.

  • idk why i love the word shake lol Mar 15, 2020 at 20:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.