2

I have Lightroom CC classic (latest version) running on windows 10 with a 1.2GB catalogue - on a SD drive and a fast computer.

However, Lightroom takes quite a time to load and most of that time the status is "Reading preferences".

I have already deleted and re-created the preference file but it did not change anything. Is there anything else I can do to debug this? Could the "reading preferences" be a misleading text while it does something else? Is my catalogue too big?

2

Based on my experience with different software products this message "reading preferences" is (kind of) misleading. And this is because it display the previous operation done by Lightroom.

Big load time is probably from the size of your catalog. Especially if you have a lot of photos inside and/or you did a lot of edit on photos. You can check this page from Adobe support forum how to split it.

| improve this answer | |
0

There can be many possible reasons for this;

Some to consider maybe as follows;

Transfer the Catalogue to your PC’s main drive and see if that improves performance. If this works then there maybe a physical communication, read/write issue between the PC and SSD.

If not, then try removing any folders from the catalogue that have images with many adjustments and edits. The loading of the Sidecar files can also slow down the process.

Remember, Lightroom is not designed for huge amounts of local adjustments such as spot removal or local corrections and if you have many images with such adjustments, then consider an editing software such as photoshop as these adjustments will slow down the load process.

Check if there is a piece of software running in the background that is using up the RAM. This will also slow down the load process.

Keep your previews as small as possible, no bigger than the actual pixel width of your display.

Check to see if you are discarding previews on a regular basis. If so, then the next time you load, it will take longer as these reviews will need to be recreated.

If you don’t use Adobe Bridge and Camera RAW, and only use Lightroom, then consider changing autowrite XMP in the Catalogue settings to manual. This process, although convenient, takes time.

Check to see you haven’t accidentally moved the cache file (.lrdata). If this has happened, then this will also slow process for you.

I am sure there are many more, but these are some that I have encountered.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.