1

I have a brand new Sager NP6855 Windows 10 Pro v1909 laptop with an Intel i7-9750H CPU that has integrated Intel UHD 630 Graphics. An external Viewsoinic 1920 x 1080 monitor is connected via HDMI to the laptop. I also have an older Eye-One colorimeter that I am using with X-Rite's i1-Match 3.6.2 software for Windows PCs. This software was released in 2009 and works on Windows 10 without any problems.

I have been doing color management for over 8 years and I understand the topic very well. I use Windows 10's control panel Color Management app to assign ICC profiles to the laptop's monitor and to the external monitor. I make these ICC profile assignments with the laptop video in the Extend display setting. I can see both ICC profiles, they are assigned to the correct displays, and everything works as expected.

As soon as I change the video display setting to either "Second screen only" or "PC screen only" Windows 10 thinks that the external monitor is Display #1 and assigns the Display #1 ICC profile to the external monitor. The problem is that Display #1 is the laptop monitor, not the external monitor. When I launch Settings> System> Display and click on "Identify," the external monitor is identified as Display #2, which is correct. However, when I launch the control panel Color Management app and click "Identify monitors" the external monitor is identified as Display #1. I believe that because the control panel Color Management app reports the external monitor as Display #1 that that's the reason that the laptop monitor's ICC profile is being assigned to the external monitor, which is Display #2. This prevents me from using the correct ICC profile on the external monitor, which is where I do 99% of my work.

Has anyone seen this problem? If so, what did you do to fix it? I've read that Microsoft released KB4505903 to fix some of these issues prior to the release of v1909. According to articles I've read, the fixes offered by KB4505903 are supposed to be present in v1909, therefore I haven't downloaded and applied KB4505903. Is there a Microsoft fix for this problem or maybe a third party app that takes ICC profile management completely away from Windows 10 (which I would be THRILLED to use!).

Thanks In Advance For Your Help!

4
  • Does the software you use to calibrate your screens have a profile loader? DisplayCAL has one, but no idea if it would address your issue. – xiota May 17 '20 at 0:00
  • Any chance it's a conflict between your laptop's video driver and Windows color Management app? Just a thought. – Philly May 17 '20 at 2:23
  • @xiota, I use Eye-One Match software with an Eye-One colorimeter. Once the colorimeter profiling is complete the Eye-One Match software saves the profile numbers as a .icc file in the C:\Windows\System32\drivers\etc\color folder. Once it is saved it becomes available to the control panel Color Management app and I can select to use it on either monitor. – Bill Vallance May 17 '20 at 3:05
  • @Philly, I just downloaded and installed the latest non-Beta Intel UHD Graphics 630 driver this afternoon. I had also tested your idea this afternoon. It appears that the Intel graphics driver is controlled by Windows 10. Whenever I was in the Extend display mode the Intel graphics software showed two monitors and their individual settings. But when I went to either of the other single-display modes only one monitor showed in the Intel graphics software. – Bill Vallance May 17 '20 at 3:08
0

I found the problem after spending more time testing whether or not the i1-Match 3.6.2 software could be the issue or whether it was Windows 10 color management. I disabled i1-Match's CalibrationLoader.exe and nothing changed. I then disabled i1-Match's ProfileReminder.exe and nothing changed. I even disabled the Windows Calibration Loader scheduled task (found at Task Scheduler Library\Microsoft\Windows\WindowsColorSystem) to see if that was the problem. Again, nothing changed.

I then focused my testing on the Windows 10 control panel Color Calibration app. The user interface on this app is abysmal. It's completely confusing - even for those of us that have dealt with it though the years with Windows 7. I tested adding and deleting .ICC profiles when Windows 10's display (known euphemistically by Microsoft as the "Project mode") was set to "Extend," "PC screen only," and "Second screen only." What I discovered is that the display mode is the key to configuring the control panel Color Management app correctly. Below are the steps I take to get all Windows 10 display modes to work with the correct .ICC profile.

  1. Begin the process of clearing old .ICC profile settings from the registry by saving, then deleting, ALL custom .ICC profiles (whether you created them or downloaded them, it doesn't matter) from the C:\Windows\System32\spool\drivers\color directory. MAKE SURE YOU HAVE SAVED A COPY OF EVERY .ICC PROFILE YOU WILL BE DELETING.
  2. Put your display in the "Extend" mode. THIS IS CRITICAL - you won't be able to view your laptop monitor and external monitor profiles unless you are in the "Extend" mode. Launch the control panel Color Management app. Click on the "Advanced" tab. In the window that opens, click the "Change system defaults ..." button located at the bottom-left of the window. This will open the System Defaults window where you can change the .ICC profile defaults for both the laptop monitor and the external monitor. At the top of this screen is a drop-down list labeled "Device:" which contains a list of all the devices that have been installed in the computer that are capable of using .ICC profiles. The first listing(s) are usually the displays that are present on the computer. Because the display mode is in "Extend" you should see two displays - one labeled "Display: 1. ..." and the other listed below it labeled "Display: 2. ...".
  3. Click "Display: 1. ..." This usually is the laptop display (not the external display). If there are any .ICC profiles listed, click each one in turn and remove them by clicking the "Remove" button. Do the same thing for "Display: 2. ..." This will clear out any existing .ICC profiles from the registry when the laptop is restarted.
  4. Close all Color Management app screens. The re-launch the Color Management app. On the opening screen in the bottom-right corner click the "Profiles" button. One of the options listed should be "Reset my settings to the system defaults." Click this option - it will delete any .ICC profiles from BOTH the Display: 1 and Display: 2 monitors. Close the Color Management app.
  5. Restart the computer. Make sure your display mode is "Extend." Then re-launch the Color Management app and confirm that no .ICC profiles are listed for either Display both on the opening screen AS WELL AS THE SYSTEM DEFAULTS SCREEN. If no .ICC profiles are listed on either screen you have successfully deleted all .ICC profile references in the registry.
  6. With the Color Management app still open, navigate to the System Defaults window (if you aren't already there). Select Display: 1 and add its .ICC profile - this is usually the laptop monitor. Do the same for Display: 2 (these should be different .ICC profiles). When you add the .ICC profile for Display: 2 add an .ICC profile that will generate a noticible color shift from the Display: 1 .ICC profile (an .ICC profile from a different computer usually works best. Don't worry, you can replace this "test" .ICC profile with the correct .ICC profile for Display: 2 later). Close the Color Management app. Then re-open the Color Management app and click the "Profiles" button on the opening window. Click the "Reset my settings to the system defaults" to make the two .ICC profiles you just added for Display: 1 and Display: 2 the defaults for these two displays. Close the Color Management app.
  7. Now test your new default .ICC profiles. Select the "PC screen only" display mode. After the display has changed to the laptop monitor, launch Settings> System> Display to view the name of the color profile for the laptop monitor (you will need to click on the Display 1 monitor icon to see the color profile name). This should be the name of the .ICC profile you assigned to Display: 1 in the color Management app.
  8. Now test the .ICC profile for the external monitor. Change the display mode to "Second screen only." Launch Settings> System> Display to view the name of the color profile for the external monitor (you will need to click on the Display 2 monitor icon to see the color profile name). Uh oh - the external monitor .ICC profile name is the same as the .ICC profile name for the laptop monitor! This is a problem with the interaction between Settings> System >Display, the Color Management app, and the Windows display mode. The issue arises because in the "PC screen only" and "Second screen only" display modes the monitor number is always assigned as "1". Since the .ICC profile name in the Color Management app for Display: 1 is the name of the laptop monitor .ICC profile, when the "Second screen only" display mode is entered and the monitor number is assigned as "1", the .ICC profile name for the Color Management app Display: 1 is presented as the color profile name in the "Second screen only" Settings> System >Display app!
  9. To fix this problem, the .ICC profiles for both the Display: 1 and Display: 2 devices in the control panel Color Management app must be present. These .ICC profiles must be present in the Display: 1 device only and NOT the Display: 2 device. This is because the Display: 1 device is displayed whenever the display mode is "PC screen only" or "Second screen only" because the monitor number for both the "PC screen only" and "Second screen only" display modes is "1". Add the external monitor's .ICC profile to the system default Display: 1 device in the Color Management app. Then close the Color Management app, re-open it, and for each Display (1 & 2) click the "Profiles" button on the opening window and click "Reset my setting to the system defaults." Now, whenever you are in either "PC screen only" or "Second screen only" display mode, the "Color Profile" drop-down in Settings> System >Display should show both the laptop monitor and the external monitor .ICC profiles. Simply click on the external monitor's .ICC profile name when you are in "Second screen only" display mode to correct the incorrect, automated, selection of the laptop monitor .ICC profile name for the external monitor in Settings> System >Display.

I hope I've covered everything I discovered during my testing. My laptop color correction now works perfectly when changing display modes between "PC screen only," "Extend," and "Second screen only." BTW - Don't forget to replace the "test" external monitor .ICC profile with the actual profile for your external monitor.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.