2

I have a Nikon D610 which worked just fine for many years. It has only 15K clicks. When I turn the camera on there is no problem until I take a shot. The picture comes out just fine but after I took a picture the light meter wont show any measurements any more and the camera shows a blinking "Err". When I turn the camera off and back on everything works again. Also I cant seem to enter Live View. Each time I try to I hear the mirror flipping up and back down again. When no lens is attached the problem is literally gone. I can take a burst of shots without any errors and the light meter works all the way through. I can also enter Live View with no lens attached. I already tried different lenses which does not change anything. By the way all my lenses are modern nikon lenses. No third party lenses.

I already cleaned the pins on each lens and also the ones inside the camera. I also flashed the firmware but nothing helps. Do you have any hints?

3

The most common cause for the Err message is an issue with the aperture control. A lack of aperture control would also likely affect metering and quite probably live-view (exposure preview).

Since you cleaned the contacts on the lens I would assume it's not an older lens with a manual aperture ring (which needs to be locked in the minimum aperture position). And that would make the aperture control lever/connection the most probable issue IMO. Does the lens aperture function as it should when removed from the body (spring loaded wide open)? Does the aperture lever on the body look ok and not loose?

There are also some other possible causes listed on Nikon's support pages: https://www.nikonimgsupport.com/eu/BV_article?articleNo=000005282&configured=1&lang=en_GB

| improve this answer | |
  • 1
    The aperture lever was causing the problem. After you gave this hint I looked closer and indeed - it was a little bit bend inwards. I used pliers to bend it back very carefully. This solved the issue right away. Thank you very much! – Arjihad May 8 at 17:23
3

It sounds like you may have bent the aperture lever in the camera body that contacts the aperture lever on the back of the lens. Or you may have bent the lever on the back of the lens that the camera's lever pushes to stop down the aperture just before the shutter opens. This is a fairly common problem when changing lenses on cameras that still use mechanical, rather than electrical, aperture control. It's easy to do if the lens isn't lined up properly when you twist the lens on the camera.

You might also have pressured something into misalignment that is causing some of the electrical contacts between the lens and camera to not line up properly. Normally in such a case, though, the lens wouldn't work at any aperture other than (perhaps) wide open.

For more about mechanical aperture levers and electrically controlled apertures, please see:
Nikon D5200 overexposed shots in "auto" modes
This answer to What are the dangers of removing a lens while the camera is on?
What is an electromagnetic diaphragm?
Inconsistent exposure with same settings--why?
I changed my camera lens while my camera was on
Nikon D7000 thinks aperture of non-cpu lens is always 16 and overexposes photos

For other possible causes with Nikon cameras, please see:

Using an external battery pack with my Nikon d5200 caused glitches
Nikon D90 mirror stuck
How to fix Nikon D40x shutter not re-arming?

| improve this answer | |
  • 1
    Thank you for your answer! – Arjihad May 9 at 8:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.