2

I use a Fujifilm XT20 to shoot at the sky every 5 seconds.

Here is the final video:

https://youtu.be/vkQ4C5nGw5M

The problem is that in the last 10 seconds of the video the brightness was just all over the place.

I were using automatic aperture and automatic shutter speed.

Then I use ffmpeg on MacOS to create the video using the JPEG files

ffmpeg -framerate 30 -pattern_type glob  -i  "DSCF*.JPG" -pix_fmt yuv420p -profile baseline  output.mp4

I think the problem is caused by the changing (decreasing) ambient light as the sun set.

Is there any way I can do to reduce the flickering in the final video? e.g. during the time the photo are shot or before the creation of the final video

  • Try using manual White balance, and you could correct the white balance in a video editing software. – Tornado 77 Apr 13 at 23:50
5

Everything should be set to manual, nothing should be automatic. What's happening is the camera is trying to compensate/adjust for each and every frame. Turn off any setting that would automatically adjust anything.

I made one once, I thought I had everything set correctly and when I rendered it to video it did the same light variance/flickering that you are having with this one.

I checked everything and realized that some of the frames had different exposure values. I then checked my camera and sure enough I had left it set to Auto ISO. That one setting caused the flickering and choppiness.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.