2

I have a rather old 35mm camera: a Vivitar Focus Free Motorized Film Load PS 120. I was curious if anyone has experience with this model and could offer help. It worked very recently, but today I tried to load in film and it wouldn't load automatically the way it is supposed to. I couldn't figure out if I was doing it wrong (since I have no owner's manual for this camera). I replaced the batteries, but the film still won't advance automatically. Thoughts?

1

You might try checking to be sure the back cover latch is working as it should. You should hear a distinct "click" when you close the door and the latch button should return to the top position of its movement. The camera will not load the film until it can confirm that the back cover is closed.

Although not for your exact model, this manual is for very similar Vivitar cameras that have zoom instead of fixed focal length lenses. The instructions regarding film loading and battery replacement should be about the same for your PS:120. Not much help there for troubleshooting your problem, however.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.