3
\$\begingroup\$

(On Windows 10.) I know that Lightroom is notorious for not letting you decide which of your secondary monitors it should use. I have 3 monitors connected to my desktop, they stand in this order [3] [2] [1]

[1] (Display port) Cheap "4K-supposed-to-be-but-not-truly-colour-graded" monitor. I use it for the main Lightroom Classic window.

[2] (Display port) "Better graded 4K monitor". I use to display the preview.

[3] (HDMI) Random 10 years old Full HD television which is mostly there to play YouTube videos or other secondary stuff while editing photography.

I haven't done any change (to my knowledge) to anything in the system, but since today, Lightroom is displaying its preview window on monitor 3.

Since Lightroom has been able to do that change the monitor it uses... any idea how to change it back?

(Changing the monitor placement is not an option considering the shapes of my desk, of apartment and of Human neck. Virtually changing monitor position is an option I though out but I don't want to get wrong "display connexions" so that would be a last resort solution.)

(Also, I noticed that the preview Windows now has a "Full screen"/"Windowed" mode... No idea if that would be the way to a satisfying solution, but I switch it to "Windowed" mode, it is display on the Full HD television with 4K dimensions, so I can't grab that window and move it to another monitor so far.)

\$\endgroup\$
1
  • 1
    \$\begingroup\$ You're probably running into this change. \$\endgroup\$ Commented Apr 3, 2020 at 21:30

3 Answers 3

4
\$\begingroup\$

Seems I found the solution faster than expected, here are the steps:

  1. Virtually switched monitor [3] and [2] in Display Settings.
  2. Switched Lightroom's preview window to "windowed" mode. That way it was still displayed on wrong monitor, but a corner of the windows was stretching out from monitor [3] to monitor [2] which I could grab.
  3. Moved preview window to monitor [2].
  4. Switched Lightroom's preview window back to "full screen" mode.
  5. Virtually switched monitor [3] and [2] in Display Settings back to their original positions.

And after a few tests so far of closing and re-opening preview window and whole Lightroom, it looks like Lightroom now memorised the right monitor as secondary.


Also, someone pointed this change: https://helpx.adobe.com/lightroom-classic/help/whats-new/2020-2.html#otherenhancements

  • In Lightroom Classic, choose Lightroom Classic > Preferences (macOS) or Edit > Preferences (Windows).
  • Select the Display tab and choose a monitor for the secondary window.
\$\endgroup\$
1
\$\begingroup\$

I think there is a faster solution to this glitch, simply by using keyboard shortcuts:

  1. Turn OFF secondary display (F11)
  2. Move Lightroom window to the secondary monitor by dragging it with a mouse
  3. Turn ON Secondary Display (F11), it should appear on the primary monitor now.
  4. Move Lightroom window to the primary display by using keyboard keys: hold WINDOWS key and keep clicking Left/Right arrow (depends on the side where you have primary window) until it gets on the proper monitor. The secondary display should automatically move to the other screen. Now just press WINDOW key and UP arrow to enlarge Lightroom to fit whole screen.
\$\endgroup\$
0
\$\begingroup\$

Not sure if this is a newer feature. But if you go to preferences, then display, you can choose which monitor to display the second screen on

\$\endgroup\$
1
  • \$\begingroup\$ Thank you. Yes, it is "new". In the sense that users struggled with the lack of this feature for years and years and at some point Adobe added it. (I think I wrote the question before the feature existed but I'm not 100% sure when it was introduced, there was a time when the feature had been released but "not noticed by everyone yet".) \$\endgroup\$
    – TTT
    Commented Dec 17, 2022 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.