1
\$\begingroup\$

The test button is not firing the flash on my Godox sk400.

It is new and the model lamp is working. Every other button is working and I have tried everything.

\$\endgroup\$
2
  • 1
    \$\begingroup\$ Have you tried firing the flash via a trigger via the radio or the PC port? Have you checked to be sure the flash tube is properly inserted in its socket? \$\endgroup\$
    – Michael C
    Feb 24, 2020 at 2:21
  • 2
    \$\begingroup\$ Is the test button supposed to actually fire the flash ? It may be testing the circuit without actually firing the flash. Check the manual to find out exactly what is supposed to happen when you use the test button. \$\endgroup\$ Feb 24, 2020 at 7:02

1 Answer 1

1
\$\begingroup\$

SK Series Backside

Please check the contacts on the flash tube, while the device is switched off. If you feel confident that there is nothing bent or looking funny, reinsert, switch on and see if the test indicator lamp (14) is lighting up. If not, there may be a problem with the device itself.

If the lamp lights up, but the lash does not fire when pressing the button (9), there is a good chance, that the flash tube itself is faulty.

Another opportunity for malfunction would be a triggered fuse (16), but I would expect the device to appear as dead and nothing working anymore until it is replaced, which is not the case here.

You might want to try triggering with a remote or via PC sync, just for the case that the test button itself is faulty.

However, the most probable cause is a faulty tube.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.