2

I have Nikon D5300 and Nikon 18-55mm AF-P DX VR 3.5-5.6G lens. I am no expert in photography just uses my DSLR to click normal pictures. I always had autofocus on half shutter press and suddenly it is not working. Images are getting clicked, but autofocus on half shutter press is not working. I have not changed any settings. I did factory reset, still no luck.

  • 1
    What is the position of the AF-MF slider on the left side of the lens? – xenoid Dec 9 '19 at 1:10
  • @xenoid I do not have slider on side of lens. – Prakash Kumar Dec 9 '19 at 3:34
  • Have you tried unmounting the lens and mounting it again? – Peter Taylor Dec 9 '19 at 6:53
  • @PeterTaylor yes done that – Prakash Kumar Dec 9 '19 at 17:32
0

Ken Rockwell says :

Nikon cautions that you need to have the latest firmware installed for it to work on the D5500, D5300 or D3300.

The problem is that the new AF-P autofocus motor system only works on camera models originally introduced since about 2013. If your camera is too old, the focus system, even in manual mode, won't work at all, making the lens completely useless with no workaround.

So it sounds like there might be a camera firmware solution for the D5300 - unless you're already using the latest version.

  • But OP said it was working, and suddenly is not working. – scottbb Dec 9 '19 at 16:44
  • I have the latest firmware. when i press half press shutter, motor does move trying to focus – Prakash Kumar Dec 9 '19 at 17:36
  • @PrakashKumar please edit your question to add that information. The fact that the motor moves while trying to focus is important to know, and helps people provide better answers and advice, rather than guessing or slowly learning bits of information piece by piece. – scottbb Dec 9 '19 at 18:10
-1

The D5300 User Manual shows the 18-55mm lens does have an AF slide switch on the side of the lens, next to the VR slider there too. The switch is marked A-M, with A being Auto Focus mode, and M being Manual focus (no Auto Focus).

The D5300 "User Manual" on Page 81 and also Page 16 shows this AF slide switch on the lens.

The D5300 "Reference Manual" is much larger and more complete than the "User Manual" and is worthwhile and free from Nikon at https://downloadcenter.nikonimglib.com/en/products/25/D5300.html

And it mentions there is also a Manual focus menu on page 51.

  • 1
    nikonusa.com/en/nikon-products/product/camera-lenses/… I have this lens, there is not slide for AF switch. even the manual focus is not working – Prakash Kumar Dec 9 '19 at 5:05
  • What do you mean by "even the manual focus is not working"? – Please Read My Profile Dec 9 '19 at 5:21
  • in reference manual it is mentioned, how to use manual focus, I tried it, but it did not work. Normally by half press shutter autofocus worked, but suddenly it stopped – Prakash Kumar Dec 9 '19 at 5:31
  • But does manual focus work? – Please Read My Profile Dec 9 '19 at 13:09
  • 1
    @WayneF I'm following your link. There is a picture on pages 82-83 (of the US version of the user manual) which clearly shows a mode switch on the AF-S II version, but not on the AF-P version — which is what Prakash says they are using. – Please Read My Profile Dec 9 '19 at 15:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.