0

It has been working all these years, and now suddenly it stopped working about half an hour into the shoot. I have tried:

  • Checking whether the flash bulb and capacitor are ok by pressing the pilot button on the flash and it fires.
  • Making sure that it is mounted correctly.

But still it does not flash. I really need someone’s help to figure out what is wrong.

I'm using the camera in full auto mode, with the flash in TTL. I've used it this way for years, without any issue.

I've used it in darker rooms, so it's not a matter of auto mode thinking it's not dark enough to require flash. When I change flash settings on the camera the changes get reflected on the flash's settings, too.

If I set the camera in M mode, with the shutter speed at 1/180s and the aperture around f/11 with the flash in TTL, it still does not flash.

I always remove the flash when I'm not using it and reattach it when there's a shoot. It's making the usual noise indicating that it connected, but just fails to fire.

  • 1
    What are the settings in camera? Have you tried other flash units to see if any of them work? – xiota Nov 24 '19 at 3:43
  • Hmm I have using the fully automatic mode the green mode, so apparently it does not let me set anything related to flash – SomeGuyWhoCodes Nov 24 '19 at 5:49
  • Ohh and in the flash it’s TTL mode – SomeGuyWhoCodes Nov 24 '19 at 6:00
  • How bright is the light in which you are shooting? is it possible that in "green box" exposure mode and TTL flash mode the camera doesn't think you need any additional light from the flash? – Michael C Nov 24 '19 at 15:01
  • I have tried in a bit darker room it still does not flash – SomeGuyWhoCodes Nov 24 '19 at 15:45
0

Communication and flash trigger usually go by different contacts since communication uses some sort of serial protocol (these days) while the trigger is very time-critical. Maybe your camera's flash shoe has lost contact or the trigger circuitry is broken? What happens with a different camera? What happens with a different flash?

  • I have yet to try with other flash. Still trying to find one. – SomeGuyWhoCodes Nov 28 '19 at 16:54
  • So apparently my flash is gone bad, I tried with new flash and it works. – SomeGuyWhoCodes Dec 17 '19 at 8:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.