I upgraded to a new Windows 10 PC recently, but now I can't figure out how to import pictures from my SD card. On my old PC, an AutoPlay window popped up as soon as a card was inserted into the computer's card reader and asked what I wanted to do with the pictures on the card, (import images / open file to view the contents etc.) but the AutoPlay window doesn't appear now and I can't figure out how to import the images. If I go to my device manager/This PC, it shows the SD card as an additional drive (not as a memory card) and I can copy and paste the images from there if I have to, but I'd rather import them properly, rather than copy them, to retain the quality. Any help would be appreciated.

  • 2
    What software are you using to view / organize / edit your photographs?
    – mattdm
    Oct 30, 2019 at 22:05

2 Answers 2


but I'd rather import them properly, rather than copy them, to retain the quality.

I don't know the answer to the Windows part of this question, but there's a fundamental worry you have here that I want to assure you over.

That "import" dialog box you were seeing before doesn't really do any magic. It just launches a program like Lightroom or some other photo manager, and that program's "import" operation copies the files from the card. This fundamentally no different from copying the image files by dragging them or using the file-manager's "copy-paste" commands. There will be no loss of image quality either way.


According to the answers.microsoft.com support question, How to import photos from SD card to Windows 10,

Open Control Panel > Autoplay, where you can choose what happens when you insert a card with image files on it.

enter image description here

From the screenshot, it appears you want to select the option, "Import photos and videos (Photos)".

  • I have autoplay set to 'ask me every time' as I thought that would prompt the pop up box to open... but it doesn't seem to want to do that! Oct 31, 2019 at 0:32
  • @SamanthaJones Ugh, this seems to be one of those annoying problems with computers. This other MS help article (Windows 10 Autoplay not working ) seems to suggest your Windows Notifications is not quite set up right. One of the respondents indicated that on their system, it had to do with Kaspersky intercepting Autoplay notifications. So perhaps firewall/AV might be causing some interaction? Ugh, sorry.
    – scottbb
    Oct 31, 2019 at 0:46
  • Many people consider Autoplay and Autorun to be dangerous.
    – Eric S
    Oct 31, 2019 at 1:59
  • @EricShain Automatically importing photos from an SDcard is a bit more specific than wholesale Autorun (which, for the record, I disabled when I had to use Windows). Setting Autoplay to import photos only, which can automatically be scanned, especially when one was going to import the photos anyways, is relatively safe (again, with the opportunity to scan).
    – scottbb
    Oct 31, 2019 at 2:34
  • Just reporting what I’ve read on various sites. Personally, I use a Mac.
    – Eric S
    Oct 31, 2019 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.