Although I can still access the CF card from the camera, I can take pictures and browse them. It's just that the mac can't mount the CF card anymore (I can read other cards). The same card was working fine before the formatting.

The very weird thing is that I can't see the CF card anywhere (not in /Volumes, not in Disk Utility) and same thing happens if I try to read the CF card by connecting the camera with the USB cable. But still I can see the content of the CF card from the camera browser. The card is a Sandisk Ultra II (2GB). And this happens since I've formatted the card from the 300D with the UnDutchables Firmware.

I have tried reading the card with a PC and I got the same result, Windows show the drive letter but throws an error if I try to open the disk.

I have also tried the same process with a different CF card and I got the same result (I can't access the CF card anymore).

Any suggestion?

  • This might gather more and/or better answers over on apple-SE or superuser-SE. Just a thought... – Jay Lance Photography Apr 22 '11 at 0:40

The UnDutchables firmware hack is based on a russian replacement firmware package which has been known to do weird things when formatting CF cards. I would suggest reformatting the card on your mac and not formatting it in camera again.

|improve this answer|||||
  • I've rolled back the firmware to the official one and tried to re-format the cards on the camera with no luck. I can't format the cards on a mac/pc because neither sees the device. :( – Federico Apr 23 '11 at 11:40
  • even Disk Utility doesn't see it? That seems odd. It may not recognize the file systems, but it should at least see the hardware. – cabbey Apr 26 '11 at 7:12
  • nope, not even Disk Utility sees the device, I know that's weird, it seems like the CF memory got completely broken by the process :( – Federico May 2 '11 at 15:49

I'm not sure what an "Untouchables Firmware" is (my assumption is that it's some 3rd-party firmware) but it sounds as if the camera has somehow formatted the card into a format that only it can read. If it's happened with a second CF card, my suspicion is that there's a problem with the camera.

Can you install a default/Canon firmware on the camera and see how it behaves at that point? I wonder if there might be a defect in the firmware you're using.

Sounds like a software problem rather than hardware...

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.