1

If I choose TTL in flash control and I set flash exposure compensation, all levels from -3 to +1 look the same.

But if I chose manual instead, and I adjust flash power from full to 1/32, the strength indeed visually changes a lot.

So is the first option not working for some reason?

Reference manual on page 199 says that the TTL option is letting the camera set the flash automatically, so this would make sense, but why don't my changes have any effect?

3
  • What specific model flash are you using? It might not be i-TTL compatible. – Michael C Sep 2 '19 at 19:43
  • What are the camera settings (ISO, aperture, shutter speed) you're using with the flash in TTL and manual modes? – xiota Sep 3 '19 at 3:45
  • My TTL control suddently started working. Problem solved, thanks anyway. – Svit Valenčič Sep 3 '19 at 18:38
1

Without more information about what specific flash you are using and what settings are selected on the flash, it is hard to narrow down the possibilities of what might be causing your issue. The three most likely scenarios are probably:

  • The flash you are using is not i-TTL compatible and is firing at full power when the camera is set to i-TTL.
  • The settings selected via the flash's control panel are overriding the camera's flash settings. Many flashes must be set to "neutral" or "default" settings on the flash's control menu for the camera's flash control menu to be able to control the flash's various settings.
  • The flash may not be properly seated in your camera's hot shoe. The center pin, which is larger, along with the ground rails on the side of the hot shoe are all that is needed to send a "fire" signal to the flash. The smaller pins communicate the data that is needed for i-TTL to work. If the flash's hot foot is not properly aligned with the camera's hot shoe, it may be that the center pin and ground rail are still making contact, even though not perfectly centered, but the smaller data contacts are not.
1
  • My TTL control suddently started working. Problem solved, thanks anyway. – Svit Valenčič Sep 3 '19 at 18:38
0

When you are using TTL, the camera is responsible for measuring flash exposure and ending the flash once sufficient exposure is reached. It sounds like you are controlling flash exposure compensation from the camera rather than the flash (you don't say so explicitly, though). In that case, it would appear that the flash ends its light independently of camera control. There may be two reasons for that:

a) it has run out of energy: the camera wants more exposure but the flash has done all it can b) it isn't interested in what the camera says because it is in automatic exposure mode, using its own scene metering. Which would mean that we are not actually talking about "TTL" at all here.

Note that even in automatic metering, the camera may be communicating ISO and aperture to the flash (and possibly effective zoom length) so that metering will work comparatively well. However, the kind of difference in behavior when a strong reflector is just inside of the frame or just outside will not be achievable.

Also, most of the time when this kind of communication level works out, actual TTL would usually work as well as long as the flash itself is in TTL mode.

It should usually have some kind of display and/or mode switch telling you that.

What kind of flash is it?

2
  • My TTL control suddently started working. Problem solved, thanks anyway. – Svit Valenčič Sep 3 '19 at 18:38
  • Your description of how TTL works is from 15-20+ years ago with film cameras. Current TTL systems (including the D3500's) use a low power pre-flash and compute the desired power before the shutter opens. – Michael C Sep 3 '19 at 19:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.