0

All the tutorials are saying the light meter (exposure meter) in live view mode should be there, except that it's not showing there in my brand new camera, lol. Is there a setting I might have set that could be preventing me from seeing it in live view mode?

  • Thanks but I've already seen this guide, it says here "M mode: The meter is always present in the Information and Live View displays and also appears in the viewfinder data display." My meter just does not appear in the live view display in M mode - my whole problem in the first place. Any ideas why? I wish I could add a photo of it here, in M mode and live view mode with no exposure meter, real pain to keep having to leave the live view mode to be able to see the light meter. – Asli Theobald Aug 29 '19 at 17:33
0

The quickest way to find out if it is a setting problem or a flaw in the camera would be to reset all options:

Shooting Menu Options | Reset Shooting Menu | Setup Menu Options | Reset all options (at the end of the menu list). That keeps your language, date, and time zone settings but puts everything else back to the factory default. You'll know then if it's something you changed or not.

Good luck!

| improve this answer | |
0

If you press the info button when in live view it cycles what info shows up. Cycle through and it should show up on one of the screens.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.