1

Yesterday i had dropped my camera and everything is working except Auto focus while using view finder but on LCD it is working fine and pictures are coming good. All is good except Auto focus, I have reset all the settings still no luck. Kindly let me know if there is anything i can do to make it working

  • What manufacturer and model camera is it? – MikeW Aug 4 '19 at 23:12
3

Chances are one or both mirrors have been knocked out of alignment... best to get it serviced.

|improve this answer|||||
  • Good answer. Viewfinder AF needs the mirror, and sub- mirror below it, to be perfectly aligned for “ phase detection” AF operation. LCD AF flips the mirror up out of the way for “contrast detection” AF operation. – Mike Sowsun Aug 4 '19 at 23:33
0

Well, it most likely would have developed a fault that resulted from the fall. Surprising how it still works well in LCD and doesn't in the viewfinder. Nonetheless, have it serviced or repaired by the Manufacturing company itself to prevent further damages. I'd advise you not to try to open it up yourself.

I honestly doubt if this would work, but try changing lenses, from kit to prime or which ever you have. If it still persists, get it fixed.

You could improve your question by including what model of camera you are talking about, a Nikon, Canon or Sony.

|improve this answer|||||
0
  • Just use the camera in Live View mode
  • Send the camera to a competent repair shop, such as an authorized service center for your camera's brand
  • Buy another camera, and don't drop that one.
|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.