1

I have a Nikon D3300 camera body and now i am planning to buy a zoom lens. And i have shortlisted this Nikon AF-P DX NIKKOR 70-300mm f/4.5-6.3G ED VR lens to purchase. But i am very confused that is all features of this lens is compatible with D3300 camera body ?

3

This lens is compatible with D3000 series cameras from the D3300 onwards, D5000 series cameras from the D5200 onwards, and D7000 series cameras from the D7100 onwards. The D500 is also compatible. Please note that compatible cameras may require a firmware update.

Source

I believe the firmware update would be necessary if the D3300 is using version 1 of the firmware, because that didn't support AF-P.

  • Thanks a ton for your detailed answer. One question: what minimum firmware version is required in camera for this lens ? – aananddham Jul 28 at 8:12
  • As far as I know, there are only two versions, and it needs the more recent one. In theory it's easy to upgrade: you don't need anything beyond the camera and the ability to copy a file onto the SD card (and if you don't have that, you'll have troubling getting the photos off it). I've never done it myself, so I can't tell you how similar theory is to practice. – Peter Taylor Jul 28 at 8:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.