Recently I tried to take a photo with my Nikon D7100. The shutter activated but no picture was stored. I tried again and got the same result. I then switched the camera off and then back on and it seems to be working correctly now. The shutter count is 42,200. Anybody have any ideas? Cheers Ian

  • \$\begingroup\$ I have no idea about that particular event, but it might be worth checking your firmware versions and updating if not current. \$\endgroup\$ Jul 11, 2019 at 21:47
  • \$\begingroup\$ Does an image come up while buffering? My wife’s mom’s Nikon by default shows the taken image while it’s being saved (at least, I believe it does this from the buffer). I’m trying to ascertain if the image is lost at the buffer or at the sd/cf card. \$\endgroup\$
    – OnBreak.
    Jul 11, 2019 at 21:50
  • \$\begingroup\$ Thanks for your replies. Hueco, I switched that function off to save battery life. It's the first time that this has happened, I think?. The SD card is about two thirds full and I only use the cards once. \$\endgroup\$
    – ian mcneil
    Jul 13, 2019 at 20:03
  • \$\begingroup\$ Is the D7100 capable of mirror lockup? Does cycling the power automatically cancel mirror lockup? \$\endgroup\$
    – Michael C
    Jul 19, 2019 at 23:39

2 Answers 2


I have seen the same issue with a D7100 (& Nikkor 18-140mm ) this week. Just as described the D7100 operated as normal and it continues to increment the image numbers. Lucky for me I spotted this early. I removed the battery and removed both Sandisk SDHC cards. After replacing the battery and then the 2 SDHC cards normal operation resumed. I am on the current firmware and lens profiles. The recorded image files have a gap of about 25 frame numbers, so some aspect of the D7100 believes it is working - but it had failed to write the missing NEF file to either of the SDHC cards.


I would try to: - Check thoroughly the integrity of the memory card. Re-format, if you think it is a healthy card; - Update firmware if possible;


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.