0

I have a Canon EOS 600D lense EF-S 18-55mm that I think may be broken or some random setting may have been activated. No physical damage/accident has happened to it. One minute it was working perfectly fine the next minute, nothing.

When I attempt to take a picture or use auto-focus nothing happens. No sound/click ect... AF is not working Manual F is not working No images can be taken on any setting Film recording IS WORKING! 🙄

I have tried all of the above advice that is relevant with no luck...I think it’s had it . It’s about 5 yrs old. I’m not an expert on cameras/photography , it’s my interest.

I do really appreciate all of your help today with this problem. Michelle.

  • 2
    Is there a lens and a card on the camera? Any chance to test another lens / card? – juhist Jul 5 at 12:18
  • 2
    Did this just start happening? Does literally nothing happen, or is there some sound, movement, or other indication? – mattdm Jul 5 at 12:30
  • Check if the camera is not set to video mode. If it isn't, it might just had got hung. Turn it off, take battery off, put it on and turn camera on again. Another chance might be autofocus not finding where to focus. Try to focus a well contrasted object on a luminous place. Look in viewfinderfor the "autofocus achieved" circular icon. If camera works but can't achieve focus, try a different lens to know where the problem is sited. – Lisan Jul 5 at 12:59
  • Wait, what do you mean by "film recording is working"? The movie / video mode? – mattdm Jul 6 at 16:43
  • What do you mean " manual f not working " You set the switch to manual focus and turn the ring but nothing happens ( focus does not change ) ? or the focus ring does not turn when you try to turn it with your hand ? – Alaska Man Jul 6 at 19:19
1

There really isn't enough here in your question for anything more than a shot in the dark. In the future, and even for this question, please edit it to explain what camera and lens combo you are using, what settings are selected, what troubleshooting you've tried, if you've bumped/damaged/got wet/lent the camera to a friend/anything that might have caused physical damage...

Lacking ANY of that, please:

  • Turn the camera off and remove the battery
  • Replace the battery and turn the camera on, make sure a lens is attached
  • Make sure the lens's Autofocus switch is set to AF
  • Turn on all of the lights in the house/room or go outside during the day. Make sure there is a lot of light.

Set your camera settings to:

  • AF Mode: AI Servo
  • Shooting mode: Manual (M)
  • Autofocus point selected: Center

Now, attempt to focus on something. Does the camera try to obtain focus? If yes, move to something else. Did the camera try to obtain focus? Good.

Now, take the shot. Your camera will have captured an image that, due to not actually setting any shot settings, is likely junk. That's not the point here - it captured a shot.

Now, let's start going backwards to what your normal settings probably are. Put the AF Mode to One Shot. Repeat this exercise. Did you get a shot? Great!

Finally, change the Shooting Mode back to whatever you normally use (Tv, Av, Sport mode...whatever). Repeat the exercise. Did you get a shot? Does it look good?

If your camera failed to product results through any of the above tests, please edit your question to explain which test you attempted, what the behavior of your camera was, and what it did not do (failure to attempt focus, failure to capture).

Thanks,

  • Additional step: Confirm the Lens is in auto-focus mode. A Manual Focus lens with Focus-Confirmation enabled will result in a camera that appears to refuse to take photos without an obvious explanation why. – TheLuckless Jul 5 at 17:41
  • @TheLuckless great point! – Hueco Jul 5 at 17:45
0

If you have a remote shutter control, try that. The shutter button is a large control with usually multiple contacts points that is usually operated more often than any other control. They tend to be among typical parts giving up their ghost and often replacement parts and instructions can be found if you look long enough. Does focus lock still work as usual? In my experience, that tends to give up earlier than the shutter release itself, but that's probably not a surefire thing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.