0

This question already has an answer here:

I have the Canon EOS 70D with the standard 18-135 lens on it. The camera was working fine and I dropped the aperture down when taking a photo and the camera froze. I turned it off and when I turned it back on, I get the following message:

Err 01 - Communications between the camera and lens is faulty. Clean the lens contacts.

I took the lens off and put it back on - no change.

I then cleaned the lens contacts - no change.

I tried a different lens incase it was the lens - no change.

I tried with a lens attached - same error coming up.

I can't access any menu options etc, as soon as I turn the camera on - this error comes up and I can't do anything on the camera.

Can someone tell me how to fix this issue as I have a shoot in around 5 hours and this has happened.

Thanks

marked as duplicate by scottbb, Hueco, inkista, xiota, mattdm lens Jul 16 at 19:18

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • When you remove the lens from the camera, is the lens' aperture wide open or stopped down? – Michael C Jun 28 at 23:14
0

In case you haven't already done it, take battery off and put it in again. Try doing this with no lens on body.

If that doesn't solve it, check if the body contact pins are ok. Maybe it's them which are dirty, or maybe there's a stuck or broken on. If they are ok, clean them with a dry cloth and try again.

If this is not working, you might consider checking your camera's software on Canon Digital Photo Professional (you can download it freely from Canon's official websites). You'll need to plug your camera in by USB.

Done this, I can't help more than tell you to send it to official repair.

I've solved a error (don't remember which) on a Rebel t6s by hitting it against the ground, but I wouldn't advise anyone to do that!

Not the answer you're looking for? Browse other questions tagged or ask your own question.