0

I recently cleaned my Canon 50mm f/1.8 STM lens using eyeglasses cleaner and a microfiber cloth. A few minutes afterward, I noticed condensation inside the lens, so I placed it in a safe place and let it dry out.

The problem: When I connect the lens to my camera (80D), it reads that the aperture is always "00", and gives Err 01 when I try to take a photo. Other lenses still work fine.

What I have tried:

  1. Cleaning the lens contacts. This is suggested by everyone, it didn't work.
  2. I disassembled the back end of the lens and looked inside. (I am comfortable working with electronics, and the warranty wouldn't cover damages if a liquid was involved in any way.) I don't see any damage to the inside circuits.

picture of back of lens, with plastic cover off

Is this a known problem, or is there a known solution? Please help, any suggestions are appreciated.

  • 2
    Just to help avoid issues in the future: Anytime you use a cleaning fluid to clean a lens, you should apply a modest amount to the cloth and then wipe the lens element with the damp spot on the cloth. You should never apply a liquid directly to a lens! – Michael C Jun 5 at 6:17
1

If the problem is sporadic, then maybe it could be caused by dirty contacts.

That said, statistically speaking, that error is nearly always caused by a torn aperture ribbon cable. A loose cable connection or a cold solder joint at either end of that ribbon cable could also potentially be the cause.

Either way, the problem is that the electrical connection between the lens's control board and the aperture mechanism has failed such that the lens's control board can no longer read the current position of the aperture.

It is extremely unlikely that this failure was caused by condensation or any other sort of moisture — unless by condensation you mean "I accidentally dropped in the ocean, and it worked fine for a week, so I thought everything was okay," in which case obviously corrosion is a possibility. But realistically, it is probably just a mechanical failure of the aperture ribbon cable, and that cable needs to be replaced.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.