I have the Canon EOS 400D - also known as EOS Digital Rebel XTi, or Kiss Digital X in Japan - and as of tonight, it stopped working. It won't do anything, with or without batteries or a CF card, except flash a blue light in the top left when batteries are inside.

I've tried taking both batteries out, the CF card out, letting the capacitors drain (someone suggested) but it still won't work. I know the power works because that blue light keeps flashing. It won't be read by the computer through a direct connection, and I don't have a CF card reader.

I looked inside and it seems like a pin is missing. CF card seems to bear the scars too. I've never looked too closely at the CF card before, so I don't know if the pin was missing before. I have a feeling that's the cause, though.

What can I do?


Missing pin, not bent, but missing. Could this cause the lack of function and the blue flashing light?


I'm no expert, but this looks damaged.


  • \$\begingroup\$ could you give us some pictures of the damages? is the batterie fully loaded for sure? \$\endgroup\$
    – LuZel
    Commented May 21, 2019 at 12:34
  • \$\begingroup\$ Images added. The battery is definitely loaded - I tried both, which are both fully charged. \$\endgroup\$
    – cai v
    Commented May 21, 2019 at 13:48
  • \$\begingroup\$ Did you try and remove the lens and try to start it? \$\endgroup\$
    – Andreas
    Commented May 21, 2019 at 14:34
  • \$\begingroup\$ I had the same issue with a Canon Rebel T2i and other cameras before; I used a pencil eraser to clean the contacts of the battery terminals inside the camera to remove corrosion. Be careful not to push too hard or else you will get eraser shavings inside. \$\endgroup\$
    – alexyorke
    Commented May 21, 2019 at 15:14
  • 1
    \$\begingroup\$ The far right pin on the lower row is not missing, but it is bent and thus not reflecting light at the same angle as the other pins. Does the camera turn on with no card installed? \$\endgroup\$
    – Michael C
    Commented May 21, 2019 at 15:56

1 Answer 1


The blue light usually indicates file transfer so it may think that it is connected to a computer and trying to transfer files. Try plugging in a USB cable when it is on then pulling it out and see if that gets it out of the loop.

Also try cleaning all the ports and checking if the coin shaped battery needs replacing.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.