2

I'm using Draktable and it takes a long time to export all my images. Something like a few hours since there are plenty of images. As I'm monitoring my CPU usage, I do see Darktable making use of my all CPU cores for its GUI. But when it comes to exporting, it only uses one core. Is there any way to ask Darktable to use all my CPU cores?

Here are the versions that I'm using:

Darktable: 2.4.2
OS: Kubuntu 18.04

Here's a screenshot of my Darktable config:

enter image description here

BTW, I do have a GeForce GTX 1080 ti as well. But it is not used at all while I'm exporting images!

+-----------------------------------------------------------------------------+
| NVIDIA-SMI 396.54                 Driver Version: 396.54                    |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 108...  Off  | 00000000:01:00.0  On |                  N/A |
| 13%   55C    P2    79W / 280W |    726MiB / 11175MiB |      3%      Default |
+-------------------------------+----------------------+----------------------+
  • Hello and welcome to photo.se What operating system are you using? – Alexander von Wernherr May 20 at 14:06
  • 1
    Have you enabled the OpenCL support in Darktable ? It helps processing the images with the GPU. – jihems May 20 at 14:42
  • All I can see there is 'number of background threads' but it doesn't say when it might use those or what for. Usually, for something like video compression that eats processors for breakfast, the task itself will be totally separate from the editor & will know to use 'all real cores' [because hyper threading doesn't help when cores are actually maxed out] to divide the task up into chunks. – Tetsujin May 20 at 16:06
  • wouldn't darktable.org/tag/forums be a more appropriate venue for this? – Fábio Dias May 21 at 17:12
3

I've found what my issue was. In Darktable, I was creating a style based on the history of one image and then, I would select all the images in lighttable mode and apply that style to all the images by double-clicking on the style. Then I would export those images.

Seems like, this is not the way to work with Draktable. The proper way of doing this is to select the created style in the export selected section before exporting. That way Darktable makes much better use of your CPU cores.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.