1

When I set up my P900 for time lapse star trails it shows the ISO as 100 in the bottom left of the monitor screen and no matter what I have tried, I cannot change the ISO to say, 1600 or 3200 for a shoot. I have changed the ISO setting to 3200 in M P A S mode but when I go to time lapse star trails the ISO still shows as 100. Is there a way to change the ISO setting? Thanks for any help.

  • 1
    What exposure mode are you using when you "set up (your) P900 for time lapse star trails?" – Michael C May 8 at 8:04
  • I set up mode as follows - Scene --then Time-lapse movie -- then Star Trails (150 minutes). I must say also that I had set the ISO to 3200 in Star Trails the night before I wanted to take the movie and it remained as 3200 until I stupidly started to press buttons on the camera just before taking the movie when I noticed it was now ISO 100. – JacKoz May 8 at 8:44
  • ISO 3200 on long exposure is not likely to yield a desirable result with a sensor that small.... the camera probably doesn't offer that for a reason. – rackandboneman May 8 at 11:54
  • You are correct regarding long exposures but the Star Trails exposure setting in the P900 is not a long exposure. It is an auto setting that opens the shutter for a 25 or 30 second exposure and then closes the shutter for some seconds before opening it again for 25 or 30 seconds. It does this for 150 minutes and then processes all the shots into a 10 second movie of star trails. Friends who also have this camera can set it for ISO 1600, 3200 and 6400 but I can't change mine from ISO 100. – JacKoz May 8 at 14:11
  • 30 seconds is a long exposure. – rackandboneman May 8 at 14:18
3

From Nikon P900 field test imaging-resource.com:

High ISO Performance

[...] The camera's ISO sensitivity setting affects the camera's maximum exposure times. Only at ISO 100 can the camera shoot at its maximum shutter speed of 15”. At ISO 200, the maximum shutter speed is 8”. At ISO 400, the maximum shutter speed is 4”. At ISO 800, it's 2”. At ISO 1600, it's 1”. At ISO 3200 and 6400, it's ½”. Even in full manual mode, these limits remain. Unfortunately, this means that the P900 cannot be used for any night landscape work that doesn't feature a lot of artificial light.

It sounds like whatever you did after setting ISO 3200 in Star Trails mode set the shutter bulb to 8–15 seconds, which caused the camera to limit ISO to 100.

  • 1
    Thanks for your information - I think that is what I did do. It was dark, cold and I was flustered and pressed too many buttons. Now to find a method of changing back from ISO 100. – JacKoz May 8 at 14:16
  • All solved now - the ISO in Star trails is pre-set at 100 and it cannot be changed come hell or high water. You can change the ISO in all modes except the pre-set ones which includes Time-lapse. I was wrong and my friends were wrong. – JacKoz May 10 at 11:14
  • Aso thanks guys for your comments and help. Until the next problem, see ya. – JacKoz May 10 at 11:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.