1

I am a brand new user of the Phottix Odin II and the LumoPro LP180R. In order to set the power level of the flash on the Odin, I have to have the LP180R set to TTL. When the LP180R is set to TTL, I am unable to set the zoom level with the Odin. If I have the LP180R set to Manual, I can set the zoom level but not the power level. What am I missing? Some help please.

  • Just a wild guess because I've never used Odin 2 or LumiPro, but with many radio controllers that control power remotely, the power on the strobe must be initially set to 1:1 for the controller to be able to alter it. If the strobe is already set using the strobe's control panel) to a value other than 1:1 ( or '0' FEC for TTL), the strobe will ignore power commands from the controller. Have you tried setting the strobe's power level to 1:1 (100%", full power, etc.) and then trying to adjust it with the Odin 2 while in manual power mode? – Michael C May 3 at 2:32
  • Ditto with the zoom setting. For most systems, it must be initially set to 'Auto' via the flash's control panel for the controller to be able to change it. – Michael C May 3 at 2:36
1

It could be that your LumoPro LP180R is on an older firmware version that doesn't know about the Odin II transmitter (the LP180R came out before the Odin IIs did). The current firmware version with full Odin II compatibility is v1.14.

Alternatively, if you can return the LumoPro, you could get a Phottix Juno or Juno TTL flash instead. The Juno models have the advantage of being firmware upgradeable to Phottix's new Odin Z system.

Also, if you didn't need the TTL signalling of the Odin II transmitter (which, if you got an LP180R and not a Mitros+ or Juno TTL, you weren't planning on using, anyway), there is now also the Odin Lite transmitter.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.