2
\$\begingroup\$

Before you jump to a conclusion, I did not format the card nor did I delete the photos. I didnt shoot on demo mode either.

This is what happened,

I came home after a vacation with 600 pictures, they looked great on the camera. Plugged the card into the card reader, pictures showing up on the PC as well. So I started copying the pictures to my hard. After 5 pics have copied a window popped up saying that can’t copy the test due to missing files.

I went back to the card from the PC, the folder which had the pictures now has nothing but some random file. I checked the capacity of the card, the full 14.6gb was full like it was when it was earlier with the 600 pictures. Below is a screenshot of the random file I see in the folder

enter image description here

As you can see, the file directory is also there. The pictures seem to have been replaced by the weird file. I cannot copy it, cut the file or move it anywhere else. Nor can I go to the properties of this file.

I tried plenty of recovery software, they didnt work either. Recovery software doesnt work.

Camera: Nikon D7100 Card: SanDisk 16GB Class 10 90Mbps

\$\endgroup\$
10
  • 1
    \$\begingroup\$ If you extract the card and resinsert it, same problem? Is the card still readable in the camera (shows images...). Did you try on a different computer? \$\endgroup\$
    – xenoid
    Apr 20, 2019 at 12:52
  • \$\begingroup\$ @xenoid Yup. Tried all that. Camera doesnt show, but it shows that the space in the card is occupied. The issue is similar in other computers as well. \$\endgroup\$
    – Ravin
    Apr 20, 2019 at 12:55
  • \$\begingroup\$ What is the size of the weird file? 16GB or so? \$\endgroup\$
    – xenoid
    Apr 20, 2019 at 13:00
  • \$\begingroup\$ @xenoid cannot check. I cant go to properties of the file and it doesnt show up a size but I assume the files are corrupted, and this weird file is a byproduct of the photos? I found sort of a similar thread online but I am not sure of using chkdsk will worsen this problem. mu-43.com/threads/… \$\endgroup\$
    – Ravin
    Apr 20, 2019 at 13:06
  • 1
    \$\begingroup\$ @JoepvanSteen if the question younasked in your comment is an earnest one, please open a new question in Photography Meta, referring to this closed question. Meta is the perfect place to expand on and discuss meta-issues. \$\endgroup\$
    – scottbb
    Jun 19, 2021 at 14:53

1 Answer 1

2
\$\begingroup\$

Since you've tried multiple readers and computers, and since you've tried card recovery software, I'm afraid the most likely thing is that the card went bad and you've lost the photos.

If the photos are absolutely precious, you may want to send it in to a data recovery company. These companies can open up the card and read from the flash chips directly. They may be able to get something, but it will cost an arm and a leg. So, this is an option best used when the data is literally priceless.

You probably didn't do anything wrong, but, in the future:

  • make sure you use genuine cards. There are a lot of fakes out there (including, sadly, on Amazon).
  • replace after a few years
  • consider a camera with dual card slots, so you can save to two cards at once (or JPEG to one card and RAW to another, so at least you have something).
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.