0

I've recently upgraded to a Nikon d750. I take photos semi professionally, but I'm still learning a few things. One annoying problem I can't seem to figure out with the new camera is when I'm taking the photo, I push the button down half way for the auto focus, and when I push it down the rest of the way to snap the picture, there is a delay of around 1 second before the photo is captured. This is very inconvenient as I'm shooting from my hands and not a tri pod. I'm assuming this is an easy setting/fix, but my camera did not come with a manual, and I can't find the solution anywhere.

  • 1
    Do you have mirror lock-up enabled? Or do you have exposure delay set (Custom Settings menu, "Exposure delay mode" (setting d4 I believe))? – scottbb Apr 13 at 23:06
  • 2
    Nikon D750 Users Manual – Michael C Apr 14 at 0:18
  • Can you try setting the camera to manual focus and seeing whether the issue persists? – Atnas Apr 15 at 18:09
1

This sounds like "Exposure delay mode". I've never used a D750 myself, but in other Nikon DSLRs this setting is found in under "Custom Setting Menu" > "Shooting/display" in the menu.

1

Could be the Release-Mode Dial (the one just below the the Mode Dial) being twisted to self-timer. Try making sure it’s on one of the first 5 settings to get immediate picture capture. You’ll need to push and hold the little button to the left of it to adjust it. See illustration below.

As mentioned elsewhere in comments and answers, you could adjust the Exposure Delay Mode to a different value if you ever do want to use the self-timer functionality.

page 7 of D750 manual

0

You have a setting causing the delay. I would do a full settings reset and try again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.