2

I have a Canon EF 50mm f/1.8 STM lens than when attached to my 100d doesn't autofocus.

I presumed the motor had gone on the lens, as it had previously worked fine

A friend has recently let me borrow his camera kit, and the "broken" lens works fine on his 5d, and all the other five lens work fine on both cameras.

Is there a setting on the 100d that I'm missing that would be causing this problem?

  • @AndyNugent Are you using viewfinder or Live view when you are trying to focus? Are you shooting video? – Michael C Apr 13 at 22:15
  • @michael-c same problem in viewfinder, live view and video. In fact in video, no "servoaf" icon appears in the bottom left (as in it's missing / blank, not that it's saying no), like when you switch to manual focus, so it appears that it isn't aware an AF lens is attached. Other lens working fine, and "broke" lens works fine on other camera (5d) – Andy Nugent Apr 14 at 9:39
  • And other lenses work fine on your 100D? – flolilo Apr 14 at 10:19
  • @flolilo yeah, the only problem is when the 100d is combined with the 50mm lens. – Andy Nugent Apr 14 at 10:29
  • @AndyNugent The 100D does not have the capability to continuously focus (that is, to use Servo AF) with any lens in video mode (or Live View, for that matter). That's why the focus mode icon disappears when you put the camera in video mode. The only mode available is 'One shot' while in LV before you press 'Record'. – Michael C Apr 14 at 22:45
1

With another lens attached switching between AF & MF on the lens causes the icon to appear / disappear. With the "broken" 50mm lens attached switching between AF & MF has no effect and it appears that it always thinks the camera is in MF (which is how it behaves hence my suspicion that this is the root cause of the problem, that the 100d for some reason is not getting the switch into AF).

With the Canon EOS EF lens system the switch is purely in the lens. There's no "AF/MF" or "On/Off" switch (hardware or software) for AF in the body on Canon cameras (like some other brands do it). That data is communicated to the camera over the same serial data pin that things such as lens info, aperture position, etc. are communicated.

enter image description here
The contact circled in red is the lens-to-camera data connection. The blue arrow is the data power supply pin and the yellow arrow is the data power supply ground.

If the lens is successfully communicating the position of the [AF/MF] switch to other camera bodies, then the problem is probably in the 100D camera body. My guess is that for some reason your 100D is not properly interpreting the signal it is receiving from the lens. It could be hardware related, but since other lenses work with your 100D, my inclination would be to think it might be due to a glitch in the camera's firmware related to information stored there specific to that particular lens or to STM lenses in general.

If you're not running the latest version of the firmware for the 100D, you could try updating to the latest version and see if that helps. Of course updating firmware always involves a slight risk. If the problem is hardware related, updating the firmware won't solve your problem. It might even make it worse.

  • I tried resetting the camera yesterday which didn't work, but did notice there's a firmware update available (from 1.0.0 to 1.0.1) and will give that a try when I have my laptop. – Andy Nugent Apr 17 at 6:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.