4

On April 6th there was the GPS week roll over, which was paired with an update of the time format from 10 bit to 13 bit.

Today I have tried to get a connection to a GPS satellite using the internal GPS feature of the Canon 6D (Mark I) and failed:

GPS Info in Camera

I see no firmware update from Canon yet. Can anyone reproduce this? What about the interal GPS on newer cameras like the Canon 5D Mark IV or Canon 6D Mark II?

  • Received an report from a Canon 6D Mark II owner for whom GPS stopped working as well. – Yaba Apr 8 at 11:13
  • Update: It's still working. See comments below. – Yaba Apr 10 at 19:13
3

The last row on your display indicates the camera doesn't have any satellite signal reception. Are you outside with a clear view of the sky?

If you are outside with GPS enabled and have waited more than a minute but still show no signal in the GPS reception signal status, then your camera may need service.

I've tested both my 5D IV (which has built-in GPS) and my 5D III using the Canon GP-E2 GPS module and both handled the roll-over without a problem.

I don't anticipate many GPS units will have a problem with the roll-over considering this is the 2nd such roll-over (any GPS that didn't understand how to deal with a roll-over event would likely already be malfunctioning before this most-recent roll-over event.)

GPS satellites drift in orbit and their orbital elements used to calculate a position fix is regularly updated. The satellites continuously broadcast those updates. If your GPS hasn't been used in a while, it can take significantly longer to get a fix. The update protocol completely re-broadcasts the GPS "almanac" in a loop that takes 12.5 minutes. As long as your GPS has a non-obstructed view of the sky, it will download the update (this is a passive thing ... you don't have to do anything other than make sure the GPS is switched on and has an un-obstructed view.) See: https://en.wikipedia.org/wiki/GPS_signals#Almanac

  • Yes, I am outside with a clear view and waited for a couple of minutes. The last time I used the GPS successfully was on Saturday, before the week roll over. The issue with this roll over is that it is not just a roll over as in the past, but also a format change of the date. – Yaba Apr 10 at 8:58
  • 1
    I would contact Canon support. It would be great to know if other 6D owners have similar issues. I would normally suspect a connection problem to the GPS module, but the notion that this issue occurred at GPS roll-over time sure seems suspicious. – Tim Campbell Apr 10 at 15:44
  • Tried again today... several minutes under clear sky - no update. Even though I set the update interval to one second. Then I took a picture, and et voila - I got a connection. Strange! Didn't notice this before that I have to take a picture. Or just a coincidence? Anyway! Thank you for your reply. Seems like it is still working. – Yaba Apr 10 at 19:12
2

My 6D got a GPS location today, Monday, April 8, 20-30 seconds after enabling GPS on the camera. I haven’t updated the firmware recently; the camera is currently at version 1.1.4.

  • 1
    I have the same firmware version. Interesting. Yesterday I waited a couple of minutes under clear sky. Will try again today. – Yaba Apr 8 at 11:57
  • Left it on for 30 minutes today. Nothing :-( It worked the day before the roll over. – Yaba Apr 10 at 9:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.