Someone sent me some very large JPEG pictures, like 15mb each. They look fine in Windows Photo Viewer (Windows 7), but they appear extremely dull and washed out in Irfanview. It's like half of the colors have gone missing, like the saturation has been turned way down.

Worse, when I save them with Irfanview, the color loss remains in the new file no matter what it's viewed with.

I thought maybe the problem was that I was using Irfanview 32-bit, but the problem remains after upgrading to 64. I've also tried changing the color management settings to no effect.

I want to re-encode them using Irfanview's batch function (they're barely encoded at all; that's why the file sizes are so large). That's my main issue, but also, I'd like to know why they look so bad simply when viewing them in Irfanview too. I've never seen this before, and I've been using Irfanview for years.

Update: I've tried opening the pictures in GIMP, and very quickly when it opens, at the bottom it says "Converting from Prophoto to sRGB built-in". The pictures look fine in GIMP.

Update: I've solved this by installing the Irfanview plugin package, then trying color management again. The color management settings say "(plugin)" in them, but apparently if you don't have the plugin installed, it just fails silently and does nothing. I installed the plugin package that contains all plugins, turned on the color management settings again, and now everything is in full color.

The actual option that I think fixed it is the bottom option, the one that says to apply sRGB to pictures without a color profile.

  • \$\begingroup\$ what formats are we talking about, where do the files come from? what did you set your settings in IrfanView, did you check in any other programs, such as XnView, GIMP, Photoshop,...? \$\endgroup\$
    – flolilo
    Mar 26, 2019 at 23:59
  • 2
    \$\begingroup\$ After update: Are you positive that in IrfanView, you have checked "Enable color management" and "Apply also for images without embedded color profile" (sRGB)? Because I cannot reproduce this behavior with these settings checked and a 16 bit ProPhoto TIF. \$\endgroup\$
    – flolilo
    Mar 27, 2019 at 0:38
  • \$\begingroup\$ @flolilolilo Do you have the color management plugin installed? That's what seems to have been the actual problem. Also it only happened on pictures with a color profile called "Prophoto", which was the cause. It's never happened on any pictures before so it probably wouldn't on whatever you're testing with. \$\endgroup\$
    – felwithe
    Mar 27, 2019 at 0:41
  • \$\begingroup\$ I rendered a picture with ProPhoto specifically, so yes, I could reproduce that - as can anyone with Lightroom and/or Photoshop, which both provide that color space natively. However, I have installed the Plug-Ins (never used IrfanView without them since they were released), so that might well be the cause. \$\endgroup\$
    – flolilo
    Mar 27, 2019 at 0:57
  • 3
    \$\begingroup\$ Now, if you are going to batch-process the images, make sure IrfanView doesn't convert them to sRGB on the go. (Although, on the other hand, if you don't normally color-manage, and are making photos for yourself, you may actually want to convert them. In any case, sending ProPhoto files (esp. JPEG!) to unsuspecting users is mauvais ton, and people who use it should know better. \$\endgroup\$
    – Zeus
    Mar 27, 2019 at 1:27

1 Answer 1


Properties -> Zoom / Color Management ->

Check "Enable color management, set display/output color profile to: (PlugIn)"

Check "Apply also for images without embedded color profile (slow!), set input ICC profile:"

enter image description here

For this to work you need the correct plugin installed. I was not sure which it was so simply installed the full Irfanview plugin package, which contained it. Without the plugin installed these options will still appear, but they will do nothing.

  • 1
    \$\begingroup\$ So what is that plugin? \$\endgroup\$ May 12, 2020 at 20:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.