0

Nikon D7100, I cannot use any of the settings or access the menu after using my YONGNUO speedlite last night. When I turn it on the camera flash pops up and the viewfinder just shows the left hand box with the flash lightning sign through the corner. Tried to set to factory settings but it would not reset. What options do I have?

  • In my question I should have also said that I took out the battery . That said, I tried it again leaving the battery out for 10 minutes instead a just a short time. Well, the longer period solved my issue and the functionality of the camera has returned. – PhotoArt360 Feb 26 at 7:47
  • 1
    You can edit the question at any time and clarify it with these details. SE sites are not threaded forums, and comments aren't really part of the Q&A. – user31502 Feb 26 at 14:30
  • Has this exact flash been used with this exact camera before without causing such grief? – rackandboneman Feb 27 at 16:11
  • Put the flash on again, and now make sure you turn the flash off before the camera. I also had it one that the camera was a bit confused and thought the flash was still attached, putting it on again fixed the issue. – Orbit Mar 4 at 12:11
-1

Be careful that your flash is not very old and a wrong voltage. Otherwise. Be sure to shut flash off before removing it.

  • 2
    Yongnuo is a Hong Kong company that makes flashes currently. I don't think they ever made old-style high trigger voltage flashes. – mattdm Mar 3 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.