2

So, I just saw this question and it got me thinking of something I stumbled upon recently.

Whenever I get a Canon camera in my hands, I read out its shuttercount using gphoto2 on Linux. What I do is basically run the following command:

gphoto2 --get-config /main/status/shuttercounter

And that works for a lot of, especially older, Canon cameras.
Now recently I got hands on a 750D and a 760D, and neither have this property. And this gets me thinking, is this really a software issue? As in, the software we use to read.

Because both of those cameras connect just fine to gphoto2, and when I run gphoto2 --list-config I get a HUGE list with all kinds of configuration entires that I can read out, but no shuttercounter property there.

So this leaves me wondering, did Canon simply drop this property? I don't really see why gphoto2 would support those cameras and a ton of properties, except for the shuttercounter. To me this sounds more like those cameras simply don't come with it. But then again I constantly see people on the internet asking makers of software like this to "update to support my camera when?", and nobody ever seems to tell them "Never.". Does anyone know more?

Could we ever read out the shuttercount of those devices? What would it take?

Edit: Here is a list of cameras supported by gphoto2. Both 750D and 760D are there.

  • I don't have a Canon to check, but have you tried exiftool & just spit out the full exif, read it manually to see if it's there but in a different guise? – Tetsujin Jan 31 at 7:54
  • @Tetsujin Holy s**t. I've used exiv2 in the past but now tried the exiftool you mentioned and it reads like hundreds of stuff off an image. However, all I see (tested on a 70D which does have the shuttercount property) is the Image Number and File Index, which is not the shuttercount, but the current image number (since last reset). – confetti Jan 31 at 8:08
  • Yeah, it has more info than you're ever likely to need ;) I've got nothing I can compare with except my Nikon, which does show as Shutter Count : 17565 – Tetsujin Jan 31 at 8:12
  • 1
    Are you using the very latest version of gphoto2? Also, most (if not all) Canon cameras do not write their shutter count into EXIF. – flolilo Jan 31 at 9:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.