-1

I have Canon PowerShot A1200 HD. When I try to turn it on, it gives me the following message: "Change the batteries".

I tried to put in new fresh batteries, but it still shows me the error message. (I inserted the batteries well)

The contacts inside the battery pack looks good.

Can someone help me, please?

Thank's.

  • 1
    "tried to put in new batteries"... Did you succeed? "it didn't work"... What didn't work - putting in new batteries? Or it didn't resolve the camera asking for new batteries, or ...? Were the batteries inserted correctly (polarity, etc.) and were they fresh or fully-charged batteries? Are the contacts inside the battery compartment clean, non-corroded, and not bent? – twalberg Jan 29 at 19:55
  • Thank you. I fixed it. – Aviad Feb 4 at 18:28
  • @Aviad, what if someone else has the same problem? They find your question and a note that you fixed it. And then nothing. Can you please first edit your question to clarify your problem and then add your solution as an answer? – Saaru Lindestøkke Feb 19 at 23:30

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.